summaryrefslogtreecommitdiffstats
path: root/testing/asterisk/102-gsm-pic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/asterisk/102-gsm-pic.patch')
-rw-r--r--testing/asterisk/102-gsm-pic.patch54
1 files changed, 0 insertions, 54 deletions
diff --git a/testing/asterisk/102-gsm-pic.patch b/testing/asterisk/102-gsm-pic.patch
deleted file mode 100644
index 71370ec0b..000000000
--- a/testing/asterisk/102-gsm-pic.patch
+++ /dev/null
@@ -1,54 +0,0 @@
---- a/codecs/gsm/Makefile.org 2008-03-29 11:33:09.000000000 +0100
-+++ b/codecs/gsm/Makefile 2008-03-29 11:44:40.000000000 +0100
-@@ -37,23 +37,6 @@
- ######### ppro's, etc, as well as the AMD K6 and K7. The compile will
- ######### probably require gcc.
-
--ifeq (, $(findstring $(OSARCH) , Darwin SunOS ))
--ifeq (, $(findstring $(PROC) , x86_64 amd64 ultrasparc sparc64 arm armv5b armeb ppc powerpc ppc64 ia64 s390 bfin mipsel mips))
--ifeq (, $(findstring $(shell uname -m) , ppc ppc64 alpha armv4l s390 ))
--OPTIMIZE+=-march=$(PROC)
--endif
--endif
--endif
--
--#The problem with sparc is the best stuff is in newer versions of gcc (post 3.0) only.
--#This works for even old (2.96) versions of gcc and provides a small boost either way.
--#A ultrasparc cpu is really v9 but the stock debian stable 3.0 gcc doesn't support it.
--#So we go lowest common available by gcc and go a step down, still a step up from
--#the default as we now have a better instruction set to work with. - Belgarath
--ifeq ($(PROC),ultrasparc)
--OPTIMIZE+=-mcpu=v8 -mtune=$(PROC) -O3
--endif
--
- PG =
- #PG = -g -pg
- ######### Profiling flags. If you don't know what that means, leave it blank.
-@@ -208,12 +191,10 @@
- # XXX Keep a space after each findstring argument
- # XXX should merge with GSM_OBJECTS
- ifeq ($(OSARCH),linux-gnu)
--ifeq (,$(findstring $(shell uname -m) , x86_64 amd64 ppc ppc64 alpha armv4l sparc64 parisc s390 ))
--ifeq (,$(findstring $(PROC) , arm armv5b armeb powerpc ia64 s390 bfin mipsel mips ))
-+ifneq ($(K6OPT),)
- GSM_SOURCES+= $(SRC)/k6opt.s
- endif
- endif
--endif
-
- TOAST_SOURCES = $(SRC)/toast.c \
- $(SRC)/toast_lin.c \
-@@ -260,12 +241,10 @@
- $(SRC)/table.o
-
- ifeq ($(OSARCH),linux-gnu)
--ifeq (,$(findstring $(shell uname -m) , x86_64 amd64 ppc ppc64 alpha armv4l sparc64 parisc ))
--ifeq (,$(findstring $(PROC) , arm armv5b armeb powerpc ia64 bfin mipsel mips ))
-+ifneq ($(K6OPT),)
- GSM_OBJECTS+= $(SRC)/k6opt.o
- endif
- endif
--endif
-
- TOAST_OBJECTS = $(SRC)/toast.o \
- $(SRC)/toast_lin.o \