summaryrefslogtreecommitdiffstats
path: root/testing/csync2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/csync2/APKBUILD')
-rw-r--r--testing/csync2/APKBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/testing/csync2/APKBUILD b/testing/csync2/APKBUILD
index 6b2ff9198..48199b305 100644
--- a/testing/csync2/APKBUILD
+++ b/testing/csync2/APKBUILD
@@ -1,6 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=csync2
-pkgver=2.0_rc1_git20121210
+pkgver=1.34_git20111201
+_ver=${pkgver%_git*}
pkgrel=0
pkgdesc="Cluster synchronization tool"
url="http://oss.linbit.com/csync2/"
@@ -10,12 +11,13 @@ depends=
makedepends="librsync-dev gnutls-dev sqlite-dev autoconf automake bison flex"
install=
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz
+source="http://oss.linbit.com/csync2/csync2-${_ver}.tar.gz
+ git.patch
03-strlcpy_disable.patch"
# 01-csync2-sqlite3.patch
# 02-csync2-1.34-gnutls_pkgconfig.patch
-_builddir="$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/$pkgname-$_ver
_giturl="http://git.linbit.com/csync2.git"
@@ -41,9 +43,10 @@ snapshot() {
prepare() {
cd "$_builddir"
- for i in ../*.patch; do
- msg "Applying $i"
- patch -p1 -i $i || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
done
autoreconf --install --force
}
@@ -62,5 +65,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="9c835a405db0ab3496239ef185bc43f2 csync2-2.0_rc1_git20121210.tar.gz
+md5sums="efc8a3548996b79cef2ad76af5e93cd8 csync2-1.34.tar.gz
+bd4957d25e984518d929ae4036bf0ae9 git.patch
e6d8aaff70cf847b11873cd1cfaaa8f6 03-strlcpy_disable.patch"