summaryrefslogtreecommitdiffstats
path: root/testing/mathomatic/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mathomatic/APKBUILD')
-rw-r--r--testing/mathomatic/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/mathomatic/APKBUILD b/testing/mathomatic/APKBUILD
new file mode 100644
index 000000000..4fa0c7a22
--- /dev/null
+++ b/testing/mathomatic/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=mathomatic
+pkgver=15.7.1
+pkgrel=0
+pkgdesc="free software computer algebra system (CAS)"
+url="http://www.mathomatic.org/math/"
+arch="all"
+license="LGPL"
+depends="m4"
+depends_dev="readline-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://mathomatic.org/mathomatic-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/mathomatic-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make READLINE=1 CC_OPTIMIZE="$CFLAGS" prefix="/usr"
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" prefix="/usr" m4install
+}
+
+md5sums="f8144e9c17edf688cbb296d20efaf808 mathomatic-15.7.1.tar.bz2"