summaryrefslogtreecommitdiffstats
path: root/testing/scstadmin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/scstadmin/APKBUILD')
-rw-r--r--testing/scstadmin/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/scstadmin/APKBUILD b/testing/scstadmin/APKBUILD
new file mode 100644
index 000000000..85350e067
--- /dev/null
+++ b/testing/scstadmin/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=scstadmin
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="SCST administration tool written in perl"
+url="http://scst.sourceforge.net"
+arch="x86_64"
+license="GPL-2"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+# increase pkgrel when updating svn rev
+_svn="3161"
+source="http://alpine.nethq.org/distfiles/$pkgname-$pkgver-svn-$_svn.tar.gz
+ scst-init-ash-comapt.patch
+ "
+
+_builddir="$srcdir"/$pkgname
+
+prepare() {
+ cd "$_builddir"/scstadmin.sysfs/scst-0.9.00
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ cd "$_builddir"
+ patch -p1 < "$srcdir"/scst-init-ash-comapt.patch
+}
+
+package() {
+ cd "$_builddir"/scstadmin.sysfs/scst-0.9.00
+ make DESTDIR="$pkgdir" install || return 1
+
+ cd "$_builddir"
+ install -Dm755 scstadmin.sysfs/scstadmin "$pkgdir"/usr/sbin/scstadmin || return 1
+ install -Dm755 init.d/scst.gentoo "$pkgdir"/etc/init.d/scstadmin || return 1
+}
+
+md5sums="8f60857b6545dd60d7d26342aba038f1 scstadmin-2.0.0-svn-3161.tar.gz
+061580b8ec84b5f7da0b1332601f505a scst-init-ash-comapt.patch"