summaryrefslogtreecommitdiffstats
path: root/testing/util-vserver/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/util-vserver/APKBUILD')
-rw-r--r--testing/util-vserver/APKBUILD67
1 files changed, 0 insertions, 67 deletions
diff --git a/testing/util-vserver/APKBUILD b/testing/util-vserver/APKBUILD
deleted file mode 100644
index 24d8150ae..000000000
--- a/testing/util-vserver/APKBUILD
+++ /dev/null
@@ -1,67 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=util-vserver
-pkgver=0.30.216_pre2864
-_realver=0.30.216-pre2864
-pkgrel=5
-pkgdesc="Linux-VServer admin utilities"
-url="http://www.nongnu.org/util-vserver/"
-license="GPL"
-install="$pkgname.post-install $pkgname.post-upgrade"
-makedepends="iptables-dev e2fsprogs-dev beecrypt-dev autoconf automake
- pkgconfig libtool"
-depends="bash make"
-
-source="http://people.linux-vserver.org/~dhozac/t/uv-testing/util-vserver-$_realver.tar.bz2
- busybox.patch
- chmod.patch
- ensc_pathprog.patch
- validate.patch
- alpine.patch
- setup-vs-template
- setup-vs-guest
- "
-subpackages="$pkgname-doc $pkgname-dev"
-
-_builddir="$srcdir"/$pkgname-$_realver
-
-build() {
- local i
- cd "$_builddir"
- for i in ../*.patch; do
- [ -r "$i" ] || continue
- msg "Applying $i"
- patch -p1 -i $i || return 1
- done
- msg "Running autotools..."
- aclocal -I m4 && autoconf && automake && libtoolize || return 1
-
- # this is an ugly workaround
- sed -i -e "s:as_echo=.*:as_echo=echo:g" configure
-
- ./configure --prefix=/usr \
- --mandir=/usr/share/man \
- --sysconfdir=/etc \
- --with-initscripts=gentoo \
- --localstatedir=/var \
- || return 1
-
- # use busybox ionice rather than util-linux-ng
- sed -i -e 's:/usr/bin/ionice:/bin/ionice:' Makefile
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir/" install install-distribution
- install -Dm755 ../setup-vs-template "$pkgdir"/usr/sbin/setup-vs-template
- install -Dm755 ../setup-vs-guest "$pkgdir"/usr/sbin/setup-vs-guest
-}
-
-md5sums="f686d72b39399fba96bbabd7debab549 util-vserver-0.30.216-pre2864.tar.bz2
-62b7b9bbe5902b95f4614272af003dfd busybox.patch
-73c7437dea6937a57cf38d166ef83c09 chmod.patch
-ff8f561f672524eb46fe633f584ef60e ensc_pathprog.patch
-da8b70c4fd40e68894b3903ffd121397 validate.patch
-04000261fd990a3963b0e98260b481bd alpine.patch
-49bca7969cc284adf68e0ef284c0660e setup-vs-template
-838511f74983453ef9827ed875b70d59 setup-vs-guest"