aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-24 15:09:32 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-24 15:09:32 +0100
commit152f7de5c7993b1e01488c99877127162e2294a8 (patch)
tree42ef76b69232ee6f90ea24a1bb904425f3a2726a
parentbd7bbc7d3b3f46c6ce99fba5f21dab39356bb714 (diff)
downloadaports-152f7de5c7993b1e01488c99877127162e2294a8.tar.bz2
aports-152f7de5c7993b1e01488c99877127162e2294a8.tar.xz
testing/py-netifaces: improve abuild
-rw-r--r--testing/py-netifaces/APKBUILD13
1 files changed, 1 insertions, 12 deletions
diff --git a/testing/py-netifaces/APKBUILD b/testing/py-netifaces/APKBUILD
index 073db94ca0..508aff7705 100644
--- a/testing/py-netifaces/APKBUILD
+++ b/testing/py-netifaces/APKBUILD
@@ -11,17 +11,7 @@ license="MIT"
makedepends="python2-dev python3-dev py-setuptools linux-headers"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-prepare() {
- local i
- cd "$builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
@@ -45,7 +35,6 @@ _py3() {
_py() {
local python="$1"
pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir"