aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-02-21 18:14:26 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-02-21 18:14:26 +0100
commit19f2f70821237554ea0aa7206f78f93cff039444 (patch)
treec3625662995655d11157af531ab666c0f940e1c7
parentc7e5fc54372eade3157a950ea34599484a854bdb (diff)
downloadaports-19f2f70821237554ea0aa7206f78f93cff039444.tar.bz2
aports-19f2f70821237554ea0aa7206f78f93cff039444.tar.xz
main/busybox: upgrade to 1.26.2
-rw-r--r--main/busybox/0001-ash-fix-error-code-regression.patch124
-rw-r--r--main/busybox/APKBUILD8
2 files changed, 3 insertions, 129 deletions
diff --git a/main/busybox/0001-ash-fix-error-code-regression.patch b/main/busybox/0001-ash-fix-error-code-regression.patch
deleted file mode 100644
index 31316726ba..0000000000
--- a/main/busybox/0001-ash-fix-error-code-regression.patch
+++ /dev/null
@@ -1,124 +0,0 @@
-From ea7d2f6ec0596789fc5b2e3fca3b7a602bfa2c26 Mon Sep 17 00:00:00 2001
-From: Ron Yorston <rmy@pobox.com>
-Date: Tue, 3 Jan 2017 11:18:23 +0100
-Subject: [PATCH] ash: fix error code regression
-
-The commit 'ash,hush: set exit code 127 in "sh /does/not/exist" case'
-only partly implemented the dash commit '[ERROR] Allow the originator
-of EXERROR to set the exit status'. This resulted in incorrect error
-codes for a syntax error:
-
- $ )
- $ echo $?
- 0
-
-or a redirection error for a special builtin:
-
- $ rm -f xxx
- $ eval cat <xxx
- $ echo $?
- 0
-
-Signed-off-by: Ron Yorston <rmy@pobox.com>
-Reported-by: Martijn Dekker <martijn@inlv.org>
-Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
----
- shell/ash.c | 8 ++++++--
- shell/ash_test/ash-misc/exitcode2.right | 4 ++++
- shell/ash_test/ash-misc/exitcode2.tests | 12 ++++++++++++
- shell/hush_test/hush-misc/exitcode2.right | 4 ++++
- shell/hush_test/hush-misc/exitcode2.tests | 12 ++++++++++++
- 5 files changed, 38 insertions(+), 2 deletions(-)
- create mode 100644 shell/ash_test/ash-misc/exitcode2.right
- create mode 100755 shell/ash_test/ash-misc/exitcode2.tests
- create mode 100644 shell/hush_test/hush-misc/exitcode2.right
- create mode 100755 shell/hush_test/hush-misc/exitcode2.tests
-
-diff --git a/shell/ash.c b/shell/ash.c
-index 430e42a7b..7c53946ce 100644
---- a/shell/ash.c
-+++ b/shell/ash.c
-@@ -1284,6 +1284,8 @@ ash_msg_and_raise_error(const char *msg, ...)
- {
- va_list ap;
-
-+ exitstatus = 2;
-+
- va_start(ap, msg);
- ash_vmsg_and_raise(EXERROR, msg, ap);
- /* NOTREACHED */
-@@ -9588,11 +9590,13 @@ evalcommand(union node *cmd, int flags)
- }
-
- if (status) {
-+ bail:
-+ exitstatus = status;
-+
- /* We have a redirection error. */
- if (spclbltin > 0)
- raise_exception(EXERROR);
-- bail:
-- exitstatus = status;
-+
- goto out;
- }
-
-diff --git a/shell/ash_test/ash-misc/exitcode2.right b/shell/ash_test/ash-misc/exitcode2.right
-new file mode 100644
-index 000000000..f7cb983c6
---- /dev/null
-+++ b/shell/ash_test/ash-misc/exitcode2.right
-@@ -0,0 +1,4 @@
-+./test.sh: line 1: syntax error: unexpected ")"
-+Done:2
-+./exitcode2.tests: line 11: can't open does_not_exist: no such file
-+Done:1
-diff --git a/shell/ash_test/ash-misc/exitcode2.tests b/shell/ash_test/ash-misc/exitcode2.tests
-new file mode 100755
-index 000000000..79a6ebd50
---- /dev/null
-+++ b/shell/ash_test/ash-misc/exitcode2.tests
-@@ -0,0 +1,12 @@
-+# syntax error should return status 2
-+cat >test.sh <<EOF
-+)
-+EOF
-+chmod +x test.sh
-+$THIS_SH ./test.sh
-+echo Done:$?
-+rm -f test.sh
-+
-+# redirection error with special builtin should return status 1
-+(eval cat <does_not_exist)
-+echo Done:$?
-diff --git a/shell/hush_test/hush-misc/exitcode2.right b/shell/hush_test/hush-misc/exitcode2.right
-new file mode 100644
-index 000000000..0a57b9b1b
---- /dev/null
-+++ b/shell/hush_test/hush-misc/exitcode2.right
-@@ -0,0 +1,4 @@
-+hush: syntax error: unexpected )
-+Done:2
-+hush: can't open 'does_not_exist': No such file or directory
-+Done:1
-diff --git a/shell/hush_test/hush-misc/exitcode2.tests b/shell/hush_test/hush-misc/exitcode2.tests
-new file mode 100755
-index 000000000..79a6ebd50
---- /dev/null
-+++ b/shell/hush_test/hush-misc/exitcode2.tests
-@@ -0,0 +1,12 @@
-+# syntax error should return status 2
-+cat >test.sh <<EOF
-+)
-+EOF
-+chmod +x test.sh
-+$THIS_SH ./test.sh
-+echo Done:$?
-+rm -f test.sh
-+
-+# redirection error with special builtin should return status 1
-+(eval cat <does_not_exist)
-+echo Done:$?
---
-2.11.0
-
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 0bc2ee33da..3f3f4c079b 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
-pkgver=1.26.1
-pkgrel=4
+pkgver=1.26.2
+pkgrel=0
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
@@ -28,7 +28,6 @@ source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
0011-ntpd-postpone-hostname-resolution-if-fails-on-startu.patch
0012-diff-add-support-for-no-dereference.patch
- 0001-ash-fix-error-code-regression.patch
location-for-cpio.patch
acpid.logrotate
@@ -147,7 +146,7 @@ static() {
"$subpkgdir"/bin/busybox.static
}
-sha512sums="2b71563185e8d9601fe57c6975473336d5950c034ed62ca51b79cc32248612770724c2f8fd2028d15892d126829ef177223496688cd6816b6c7c0203772f9886 busybox-1.26.1.tar.bz2
+sha512sums="9926d211d0b4f34b513d934d7b111ebbf933c2dc31206bdd80426a62d47d5b1475b70bec5aaa14a26b94a202ab1465d994062a002750a312dcb8167096eb3719 busybox-1.26.2.tar.bz2
ed16b7a38d99eb309ed03d3212ffd1c1993e292724665be2aaefcf645c9a37d1b0c5d24308dac7dbb093afde5b700961c55336d67be4f2bb788c85550e5f1de8 0001-ash-exec-busybox.static.patch
cd6b0b59ca8006bfc545ba521a92de81be320c0dd3ed0a41d6a60339b73f44c80f1ac36fb05d35a8555fd173167b792f73ae279115d23d59f8f623ae01aed7d1 0002-app-location-for-vi-and-lspci.patch
3fef7a3f47ca798859c5cf8d78bc36ed98c4b9f841a3593bca71b9242ca15719bbe9b683437f8ea61b9a5f6c31c9272b7f72dcb6ef6fc2a42fd3219e302113eb 0003-udhcpc-set-default-discover-retries-to-5.patch
@@ -160,7 +159,6 @@ fc291167b2e026166e283d98d2d61cb3c9701e5e83c09062692d0c5a77f3b838ba73065706461095
f82caa1dc4395f266b024a7face267a916a80ead95f3d392b10fd397d0fdf62703e3078357bc71962616d6531ea913aef80e1a7cdf8180bca70e723c7d331238 0010-su-FEATURE_SU_NULLOK_SECURE.patch
16b513b34b3bf16002f14566aae66aab986403cb7a0f416c27264b739706bbd624a99fd37d5b56ff6efe623f3cc48aef3e8fe51c4ae2e94eda3fe9e8e618e3a1 0011-ntpd-postpone-hostname-resolution-if-fails-on-startu.patch
361959788bc11b7f20d4029bb0f561759d270983b09c44fe2a01817378c4eb1c98cd8ef73e7ef8c168b7540170f58ddb36b9e4f80a97565f3fe3ba85b593a471 0012-diff-add-support-for-no-dereference.patch
-79d2ec8ad1530aacf8c5ccc5386ede252b06c3d538d1d027f9f4fc29dabcae6832939a15cbe1b78224eae9191684966e5ca5da44c046988b7fd8a55db24dc30e 0001-ash-fix-error-code-regression.patch
f26e090f5de0096ba5c4d46989ebe0ab5fa64c8bf54cd37ddec302fddfde23eac914858d86cc52bf3b5780a8e81ea2612ef6e713df2828e52c606f86a6816f39 location-for-cpio.patch
dadb4c953ebc755b88ee95c1489feb0c2d352f6e44abc716166024e6eea11ab9d10c84fad62c081775834d205cb04aa1be3c994676c88f4284495c54b9188e8b acpid.logrotate
d4b9f4a09dcf08ec9f7a66c5250465e3a6dd9beb15140a462a1464110824426c732399e4dab4e6a33073626d4db0e76085b218cd0521027e57ce9f918ff1af29 busyboxconfig