aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Sidor (Michcioperz) <public+git@meekchopp.es>2018-09-01 18:21:42 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-04 06:29:08 +0000
commit1b6f5a82da79dc31f15a6f5ed1b30e4eae925fb3 (patch)
tree2b5e6f4b208c81a3e6fc88d1e7364c27facef6ab
parentbc2b2f660231afb4c09512175e93cc236758d9f9 (diff)
downloadaports-1b6f5a82da79dc31f15a6f5ed1b30e4eae925fb3.tar.bz2
aports-1b6f5a82da79dc31f15a6f5ed1b30e4eae925fb3.tar.xz
testing/librespot: change upstream, upgrade to 20180817, fix username in pre-install
-rw-r--r--testing/librespot/APKBUILD14
-rw-r--r--testing/librespot/librespot.initd2
-rw-r--r--testing/librespot/librespot.pre-install2
3 files changed, 8 insertions, 10 deletions
diff --git a/testing/librespot/APKBUILD b/testing/librespot/APKBUILD
index ae117e786b..23760685ef 100644
--- a/testing/librespot/APKBUILD
+++ b/testing/librespot/APKBUILD
@@ -1,19 +1,18 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=librespot
-_sha=d95c0b3fcd2ddfa9d09a189d73b82090420d7f56
-pkgver=20170413
+_sha=a4e0f582a8c705b05c8abba58d9e9c1c06ad532d
+pkgver=20180817
pkgrel=1
pkgdesc="Open Source Spotify client library"
-url="https://github.com/plietar/librespot"
+url="https://github.com/librespot-org/librespot"
arch="x86_64"
license="MIT"
depends=""
makedepends="cargo portaudio-dev protobuf-dev alsa-lib-dev"
install="$pkgname.pre-install"
subpackages=""
-source="librespot-$pkgver.tar.gz::https://github.com/plietar/librespot/archive/$_sha.tar.gz
- $pkgname.pre-install
+source="librespot-$pkgver.tar.gz::https://github.com/librespot-org/librespot/archive/$_sha.tar.gz
$pkgname.initd
$pkgname.confd
"
@@ -36,7 +35,6 @@ package() {
install -Dm644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
-sha512sums="d50dd3b997061cfc7dac424e4a3413a1dff1289af7c537c76555e97c8a80b1e49a7d35a462c2228efd2b1d749285b789856b52c37b1566424802d831d995dd84 librespot-20170413.tar.gz
-05cc45f92fc609caded9d2fd552903d1aee8e62375aab57036c36c4914561b519df948924d2ab28a841a4bdabdac4a01219024249be39de26a9f520d2f69cdba librespot.pre-install
-30ad41a32cb82cae3e9df319d69aebf8149e2fae8746747c167b8e93119f07081111bc6f0245f23b3059db41caa0f6dffd9b22c7791df518d092888e79862dde librespot.initd
+sha512sums="5f32dd244ccefd257b17c3a7b736274c9e5b6b23db9df973a07c7ee93d4a1c7d8d11fc12a41314306fe26bea93ec2312f8c75b3975aba5372c3dc77642ab9325 librespot-20180817.tar.gz
+c48ea30e2bd076691a2f1e0e3f6c6329921a8cf25e4f39ca82e07aca5a1c2c519007f081f2b6bbd1566086407a52dce787450b840e8a07e3010227cefda0452a librespot.initd
4286a3d1cc9678af2f43074c30a0ab7a9f686301468a0fd435d37a62773f0d1501b7201851bef4237324a83361ad93531ceb512a42ee0a63d4d14677760f5ec5 librespot.confd"
diff --git a/testing/librespot/librespot.initd b/testing/librespot/librespot.initd
index f4ed8777ca..8a7e42ea68 100644
--- a/testing/librespot/librespot.initd
+++ b/testing/librespot/librespot.initd
@@ -5,7 +5,7 @@ command_args="${librespot_args}"
pidfile=/run/librespot.pid
command_background=true
logfile="/var/log/librespot.log"
-start_stop_daemon_args="--user ${librespot_user:-librespot} --group ${librespot_group:-librespot} --stdout $logfile --stderr $logfile"
+start_stop_daemon_args="--user ${librespot_user:-librespot} --group ${librespot_group:-audio} --stdout $logfile --stderr $logfile"
depends() {
need localmount net
diff --git a/testing/librespot/librespot.pre-install b/testing/librespot/librespot.pre-install
index c8c0e047b4..203bd5edf4 100644
--- a/testing/librespot/librespot.pre-install
+++ b/testing/librespot/librespot.pre-install
@@ -1,5 +1,5 @@
#!/bin/sh
-adduser -S -D -H -s /sbin/nologin -G audio -g audio clamav 2>/dev/null
+adduser -S -D -H -s /sbin/nologin -G audio -g audio librespot 2>/dev/null
exit 0