aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2018-10-17 17:09:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-18 16:00:57 +0000
commit1f20ed2a3356332ca8e3ec214f82323cb90929f1 (patch)
treea4a16c2d762b64389f1414bf66c28efbf2cf17c6
parent1729dd4c046d1b1dc146c28bf0d57b3e6557a228 (diff)
downloadaports-1f20ed2a3356332ca8e3ec214f82323cb90929f1.tar.bz2
aports-1f20ed2a3356332ca8e3ec214f82323cb90929f1.tar.xz
main/python3: skip minor test failure on ppc64le
-rw-r--r--main/python3/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/main/python3/APKBUILD b/main/python3/APKBUILD
index 7c5ec7dc6f..79cd72ca97 100644
--- a/main/python3/APKBUILD
+++ b/main/python3/APKBUILD
@@ -5,7 +5,7 @@ pkgname=python3
# the python2-tkinter's pkgver needs to be synchronized with this.
pkgver=3.6.6
_basever="${pkgver%.*}"
-pkgrel=1
+pkgrel=2
pkgdesc="A high-level scripting language"
url="http://www.python.org"
arch="all"
@@ -100,6 +100,11 @@ EOF
# kernel related
fail="$fail test_fcntl" # wants DNOTIFY, we don't have it
+ # just a single subtest test_memoryview_struct_module is breaking on pc64le.
+ if [ "$CARCH" = "ppc64le" ]; then
+ fail="$fail test_buffer" # fail on ppc64le
+ fi
+
make quicktest TESTOPTS="--exclude $fail"
}