aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-03-07 11:17:05 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2018-03-07 11:18:07 +0100
commit2fd76197ae6e35e29552e7466bffeb513deba924 (patch)
treefd265f9cf653dabd15ac25394d3d76498bcfa761
parent7e56c0aaff074e90cb6ab207d9c9a0bb8b40441b (diff)
downloadaports-2fd76197ae6e35e29552e7466bffeb513deba924.tar.bz2
aports-2fd76197ae6e35e29552e7466bffeb513deba924.tar.xz
testing/tcsh: add /bin/tcsh to /etc/shells
Fixes #8618
-rw-r--r--testing/tcsh/APKBUILD4
-rw-r--r--testing/tcsh/tcsh.post-install3
l---------testing/tcsh/tcsh.post-upgrade1
-rw-r--r--testing/tcsh/tcsh.pre-deinstall3
4 files changed, 9 insertions, 2 deletions
diff --git a/testing/tcsh/APKBUILD b/testing/tcsh/APKBUILD
index 54139c093b..3c713ab412 100644
--- a/testing/tcsh/APKBUILD
+++ b/testing/tcsh/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer:
pkgname=tcsh
pkgver=6.20.00
-pkgrel=1
+pkgrel=2
pkgdesc="extended C-shell"
url="http://www.tcsh.org"
arch="all"
license="BSD"
depends=""
makedepends="ncurses-dev"
-install=""
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
subpackages="$pkgname-doc"
source="ftp://ftp.astron.com/pub/tcsh/${pkgname}-${pkgver}.tar.gz
001-sysmalloc.patch"
diff --git a/testing/tcsh/tcsh.post-install b/testing/tcsh/tcsh.post-install
new file mode 100644
index 0000000000..7342c5e721
--- /dev/null
+++ b/testing/tcsh/tcsh.post-install
@@ -0,0 +1,3 @@
+#!/bin/sh
+add-shell '/bin/tcsh'
+exit 0
diff --git a/testing/tcsh/tcsh.post-upgrade b/testing/tcsh/tcsh.post-upgrade
new file mode 120000
index 0000000000..180542a18b
--- /dev/null
+++ b/testing/tcsh/tcsh.post-upgrade
@@ -0,0 +1 @@
+tcsh.post-install \ No newline at end of file
diff --git a/testing/tcsh/tcsh.pre-deinstall b/testing/tcsh/tcsh.pre-deinstall
new file mode 100644
index 0000000000..9e2e34c1c5
--- /dev/null
+++ b/testing/tcsh/tcsh.pre-deinstall
@@ -0,0 +1,3 @@
+#!/bin/sh
+remove-shell '/bin/tcsh'
+exit 0