aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-01-14 23:24:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-16 15:51:22 +0000
commit4a1f1e10bb0e662ff98bcf587a8594a192de4234 (patch)
treefbda43deea07acd11ee5a951e6393fcb559df5c3
parent7fba16c72fa48c1e80e028a9b809714a56e955a1 (diff)
downloadaports-4a1f1e10bb0e662ff98bcf587a8594a192de4234.tar.bz2
aports-4a1f1e10bb0e662ff98bcf587a8594a192de4234.tar.xz
Initial APKBUILD for p11-kit
Package description: p11-kit provides a way to load and enumerate PKCS#11 modules, as well as a standard configuration setup for installing PKCS#11 modules in such a way that they're discoverable. Website: http://p11-glue.freedesktop.org/
-rw-r--r--testing/p11-kit/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/p11-kit/APKBUILD b/testing/p11-kit/APKBUILD
new file mode 100644
index 0000000000..537ea51f4e
--- /dev/null
+++ b/testing/p11-kit/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=p11-kit
+pkgver=0.9
+pkgrel=0
+pkgdesc="Library for loading and sharing PKCS#11 modules"
+url="http://p11-glue.freedesktop.org/"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://p11-glue.freedesktop.org/releases/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="029aa2a3a103e7eb81b4aa731b93539e p11-kit-0.9.tar.gz"