aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-12-09 19:37:36 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2017-12-19 09:32:55 +0000
commit4aa3458d58c852f85db7e7da65fed35091ae5ec3 (patch)
treeab007c8be5794eec29d0c869df939f615bed37b0
parent1ddccd03c1f58f6d1396b3a4e8638cb9d3169a23 (diff)
downloadaports-4aa3458d58c852f85db7e7da65fed35091ae5ec3.tar.bz2
aports-4aa3458d58c852f85db7e7da65fed35091ae5ec3.tar.xz
testing/doas: new aport
https://github.com/Duncaen/OpenDoas OpenBSD's temporary privledge escalation tool
-rw-r--r--testing/doas/APKBUILD34
-rw-r--r--testing/doas/doas.conf4
2 files changed, 38 insertions, 0 deletions
diff --git a/testing/doas/APKBUILD b/testing/doas/APKBUILD
new file mode 100644
index 0000000000..844afc568e
--- /dev/null
+++ b/testing/doas/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=doas
+pkgver=6.0
+pkgrel=0
+pkgdesc="OpenBSD's temporary privledge escalation tool"
+url="https://github.com/Duncaen/OpenDoas"
+arch="all"
+license="BSD"
+makedepends="bison"
+subpackages="$pkgname-doc"
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/Duncaen/OpenDoas/archive/v6.0.tar.gz
+ doas.conf
+"
+builddir="$srcdir/OpenDoas-$pkgver"
+options="$options !check suid"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --enable-static \
+ --without-pam || return 1
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+ install -Dm440 "$srcdir"/doas.conf "$pkgdir"/etc/doas.conf
+}
+
+sha512sums="2bf5e00895a45d87785e7a494a1506844afd843ef5375e0b0e3795ebc24712bb941c6feeb87e426e41a240d40aca9b4c099f77220745bb7142a7a4b303441f60 doas-6.0.tar.gz
+5035ae91293953b292c430334e949e11e5b482c5c91c7f018ac8286a791568a3006499649f487547a262291c0968618522fbc14acb5e2faa2af52accf15bbc49 doas.conf"
diff --git a/testing/doas/doas.conf b/testing/doas/doas.conf
new file mode 100644
index 0000000000..57907748ab
--- /dev/null
+++ b/testing/doas/doas.conf
@@ -0,0 +1,4 @@
+# see doas.conf(5) for configuration details
+
+# Uncomment to allow group "admin" to become root
+# permit :admin