aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 08:39:18 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 08:39:18 +0000
commit53a4f790089c6699afc42a41e31ea685f1699b18 (patch)
treeed14ac80f5c185eb4de54fb27f86d60921135f5c
parentaa5fc423790c5777efdd436115790e33fa7d5475 (diff)
downloadaports-53a4f790089c6699afc42a41e31ea685f1699b18.tar.bz2
aports-53a4f790089c6699afc42a41e31ea685f1699b18.tar.xz
community/scapy: moved from testing, cleaned up APKBUILD
-rw-r--r--community/scapy/APKBUILD (renamed from testing/scapy/APKBUILD)25
-rw-r--r--community/scapy/scapy.post-install (renamed from testing/scapy/scapy.post-install)0
2 files changed, 7 insertions, 18 deletions
diff --git a/testing/scapy/APKBUILD b/community/scapy/APKBUILD
index 59556a3cf5..c09d4373eb 100644
--- a/testing/scapy/APKBUILD
+++ b/community/scapy/APKBUILD
@@ -1,39 +1,28 @@
# Contributor: Paul Kilar <pkilar@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=scapy
-pkgver='2.3.2'
+pkgver="2.3.2"
pkgrel=1
pkgdesc="Powerful interactive packet manipulation"
url="http://www.secdev.org/projects/scapy/"
arch="noarch"
license="GPL3+"
depends="python"
-depends_dev=""
-makedepends="$depends_dev python-dev"
+makedepends="python2-dev"
install="$pkgname.post-install"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.zip::https://github.com/secdev/$pkgname/archive/v$pkgver.zip"
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
- python setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build || return 1
}
package() {
- cd "$_builddir"
- python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
md5sums="06c1be0b261d36907c3ff24fa443b4aa scapy-2.3.2.zip"
diff --git a/testing/scapy/scapy.post-install b/community/scapy/scapy.post-install
index 9f2247aabe..9f2247aabe 100644
--- a/testing/scapy/scapy.post-install
+++ b/community/scapy/scapy.post-install