aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2018-09-18 01:54:54 +0300
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2018-09-18 19:23:50 +0300
commit5ba72daefa17a63227df5c786594139e6b2edc20 (patch)
treee7aa5a4b86f210e4e7d14101be0ef71f0a43b43d
parent5b0674bd606ad881c984071814c94a4dcb710a70 (diff)
downloadaports-5ba72daefa17a63227df5c786594139e6b2edc20.tar.bz2
aports-5ba72daefa17a63227df5c786594139e6b2edc20.tar.xz
main/musl: fix race condition
-rw-r--r--main/musl/0001-fix-race-condition-in-file-locking.patch51
-rw-r--r--main/musl/0001-fix-sysconf-for-infinite-rlimits.patch26
-rw-r--r--main/musl/0001-use-the-name-UTC-instead-of-GMT-for-UTC-timezone.patch137
-rw-r--r--main/musl/APKBUILD4
4 files changed, 54 insertions, 164 deletions
diff --git a/main/musl/0001-fix-race-condition-in-file-locking.patch b/main/musl/0001-fix-race-condition-in-file-locking.patch
new file mode 100644
index 0000000000..c6ec9a5e6e
--- /dev/null
+++ b/main/musl/0001-fix-race-condition-in-file-locking.patch
@@ -0,0 +1,51 @@
+From b6b592d75f694958424b8a4fbd909b52317651f1 Mon Sep 17 00:00:00 2001
+From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+Date: Tue, 18 Sep 2018 01:10:32 +0300
+Subject: [PATCH v2] fix race condition in file locking
+
+The condition occurs when
+- thread #1 is holding the lock
+- thread #2 is waiting for it on __futexwait
+- thread #1 is about to release the lock and performs a_swap
+- thread #3 enters the __lockfile function and manages to grab the lock
+ before thread #1 calls __wake, resetting the MAYBE_WAITERS flag
+- thread #1 calls __wake
+- thread #2 wakes up but goes again to __futexwait as the lock is
+ held by thread #3
+- thread #3 releases the lock but does not call __wake as the
+ MAYBE_WAITERS flag is not set
+
+This condition results in thread #2 not being woken up. This patch fixes
+the problem by making the woken up thread ensure that the flag is
+properly set before going to sleep again.
+---
+ src/stdio/__lockfile.c | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/src/stdio/__lockfile.c b/src/stdio/__lockfile.c
+index 2ff75d8a..0dcb2a42 100644
+--- a/src/stdio/__lockfile.c
++++ b/src/stdio/__lockfile.c
+@@ -8,13 +8,13 @@ int __lockfile(FILE *f)
+ int owner = f->lock, tid = __pthread_self()->tid;
+ if ((owner & ~MAYBE_WAITERS) == tid)
+ return 0;
+- for (;;) {
+- owner = a_cas(&f->lock, 0, tid);
+- if (!owner) return 1;
+- if (a_cas(&f->lock, owner, owner|MAYBE_WAITERS)==owner) break;
++ owner = a_cas(&f->lock, 0, tid);
++ if (!owner) return 1;
++ while ((owner = a_cas(&f->lock, 0, tid|MAYBE_WAITERS))) {
++ if ((owner & MAYBE_WAITERS) ||
++ a_cas(&f->lock, owner, owner|MAYBE_WAITERS)==owner)
++ __futexwait(&f->lock, owner|MAYBE_WAITERS, 1);
+ }
+- while ((owner = a_cas(&f->lock, 0, tid|MAYBE_WAITERS)))
+- __futexwait(&f->lock, owner, 1);
+ return 1;
+ }
+
+--
+2.14.4
+
diff --git a/main/musl/0001-fix-sysconf-for-infinite-rlimits.patch b/main/musl/0001-fix-sysconf-for-infinite-rlimits.patch
deleted file mode 100644
index b465f49655..0000000000
--- a/main/musl/0001-fix-sysconf-for-infinite-rlimits.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 3ec82877e7783f0706ba3c9e3c815cd2aa34059e Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu, 7 Dec 2017 23:18:54 +0100
-Subject: [PATCH] fix sysconf for infinite rlimits
-
-sysconf should return -1 for infinity, not LONG_MAX.
----
- src/conf/sysconf.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/conf/sysconf.c b/src/conf/sysconf.c
-index b8b761d0..9ce330a5 100644
---- a/src/conf/sysconf.c
-+++ b/src/conf/sysconf.c
-@@ -174,6 +174,8 @@ long sysconf(int name)
- } else if (values[name] < -256) {
- struct rlimit lim;
- getrlimit(values[name]&16383, &lim);
-+ if (lim.rlim_cur == RLIM_INFINITY)
-+ return -1;
- return lim.rlim_cur > LONG_MAX ? LONG_MAX : lim.rlim_cur;
- }
-
---
-2.15.0
-
diff --git a/main/musl/0001-use-the-name-UTC-instead-of-GMT-for-UTC-timezone.patch b/main/musl/0001-use-the-name-UTC-instead-of-GMT-for-UTC-timezone.patch
deleted file mode 100644
index ef751956ea..0000000000
--- a/main/musl/0001-use-the-name-UTC-instead-of-GMT-for-UTC-timezone.patch
+++ /dev/null
@@ -1,137 +0,0 @@
-From eb7f93c4f6fd0b637a9f8d6e112131b88ad2b00f Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu, 7 Dec 2017 17:54:07 +0100
-Subject: [PATCH] use the name UTC instead of GMT for UTC timezone
-
-notes by maintainer:
-
-both C and POSIX use the term UTC to specify related functionality,
-despite POSIX defining it as something more like UT1 or historical
-(pre-UTC) GMT without leap seconds. neither specifies the associated
-string for %Z. old choice of "GMT" violated principle of least
-surprise for users and some applications/tests. use "UTC" instead.
----
- src/time/__tz.c | 16 ++++++++--------
- src/time/gmtime_r.c | 4 ++--
- src/time/timegm.c | 4 ++--
- 3 files changed, 12 insertions(+), 12 deletions(-)
-
-diff --git a/src/time/__tz.c b/src/time/__tz.c
-index ffe8d402..8cc96032 100644
---- a/src/time/__tz.c
-+++ b/src/time/__tz.c
-@@ -15,7 +15,7 @@ weak_alias(__tzname, tzname);
-
- static char std_name[TZNAME_MAX+1];
- static char dst_name[TZNAME_MAX+1];
--const char __gmt[] = "GMT";
-+const char __utc[] = "UTC";
-
- static int dst_off;
- static int r0[5], r1[5];
-@@ -126,7 +126,7 @@ static void do_tzset()
-
- s = getenv("TZ");
- if (!s) s = "/etc/localtime";
-- if (!*s) s = __gmt;
-+ if (!*s) s = __utc;
-
- if (old_tz && !strcmp(s, old_tz)) return;
-
-@@ -136,7 +136,7 @@ static void do_tzset()
- * free so as not to pull it into static programs. Growth
- * strategy makes it so free would have minimal benefit anyway. */
- i = strlen(s);
-- if (i > PATH_MAX+1) s = __gmt, i = 3;
-+ if (i > PATH_MAX+1) s = __utc, i = 3;
- if (i >= old_tz_size) {
- old_tz_size *= 2;
- if (i >= old_tz_size) old_tz_size = i+1;
-@@ -165,12 +165,12 @@ static void do_tzset()
- }
- }
- }
-- if (!map) s = __gmt;
-+ if (!map) s = __utc;
- }
- if (map && (map_size < 44 || memcmp(map, "TZif", 4))) {
- __munmap((void *)map, map_size);
- map = 0;
-- s = __gmt;
-+ s = __utc;
- }
-
- zi = map;
-@@ -207,7 +207,7 @@ static void do_tzset()
- }
- }
- if (!__tzname[0]) __tzname[0] = __tzname[1];
-- if (!__tzname[0]) __tzname[0] = (char *)__gmt;
-+ if (!__tzname[0]) __tzname[0] = (char *)__utc;
- if (!__daylight) {
- __tzname[1] = __tzname[0];
- dst_off = __timezone;
-@@ -216,7 +216,7 @@ static void do_tzset()
- }
- }
-
-- if (!s) s = __gmt;
-+ if (!s) s = __utc;
- getname(std_name, &s);
- __tzname[0] = std_name;
- __timezone = getoff(&s);
-@@ -413,7 +413,7 @@ const char *__tm_to_tzname(const struct tm *tm)
- const void *p = tm->__tm_zone;
- LOCK(lock);
- do_tzset();
-- if (p != __gmt && p != __tzname[0] && p != __tzname[1] &&
-+ if (p != __utc && p != __tzname[0] && p != __tzname[1] &&
- (!zi || (uintptr_t)p-(uintptr_t)abbrevs >= abbrevs_end - abbrevs))
- p = "";
- UNLOCK(lock);
-diff --git a/src/time/gmtime_r.c b/src/time/gmtime_r.c
-index 8cbdadcb..cba72447 100644
---- a/src/time/gmtime_r.c
-+++ b/src/time/gmtime_r.c
-@@ -2,7 +2,7 @@
- #include <errno.h>
- #include "libc.h"
-
--extern const char __gmt[];
-+extern const char __utc[];
-
- struct tm *__gmtime_r(const time_t *restrict t, struct tm *restrict tm)
- {
-@@ -12,7 +12,7 @@ struct tm *__gmtime_r(const time_t *restrict t, struct tm *restrict tm)
- }
- tm->tm_isdst = 0;
- tm->__tm_gmtoff = 0;
-- tm->__tm_zone = __gmt;
-+ tm->__tm_zone = __utc;
- return tm;
- }
-
-diff --git a/src/time/timegm.c b/src/time/timegm.c
-index b5dae8b6..f444e76e 100644
---- a/src/time/timegm.c
-+++ b/src/time/timegm.c
-@@ -2,7 +2,7 @@
- #include "time_impl.h"
- #include <errno.h>
-
--extern const char __gmt[];
-+extern const char __utc[];
-
- time_t timegm(struct tm *tm)
- {
-@@ -15,6 +15,6 @@ time_t timegm(struct tm *tm)
- *tm = new;
- tm->tm_isdst = 0;
- tm->__tm_gmtoff = 0;
-- tm->__tm_zone = __gmt;
-+ tm->__tm_zone = __utc;
- return t;
- }
---
-2.15.0
-
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index 4179769a00..a3f2ea266c 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=musl
pkgver=1.1.20
-pkgrel=0
+pkgrel=1
pkgdesc="the musl c library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -16,6 +16,7 @@ esac
source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
2000-pthread-internals-increase-DEFAULT_GUARD_SIZE-to-2-p.patch
handle-aux-at_base.patch
+ 0001-fix-race-condition-in-file-locking.patch
ldconfig
__stack_chk_fail_local.c
@@ -142,6 +143,7 @@ compat() {
sha512sums="d3a7a30aa375ca50d7dcfbd618581d59e1aa5378417f50a0ca5510099336fd74cc9db468e05c93dda3067abd890f6bd47af226c3446bb833adf0a5054bff2e5d musl-1.1.20.tar.gz
2c8e1dde1834238097b2ee8a7bfb53471a0d9cff4a5e38b55f048b567deff1cdd47c170d0578a67b1a039f95a6c5fbb8cff369c75b6a3e4d7ed171e8e86ebb8c 2000-pthread-internals-increase-DEFAULT_GUARD_SIZE-to-2-p.patch
6a7ff16d95b5d1be77e0a0fbb245491817db192176496a57b22ab037637d97a185ea0b0d19da687da66c2a2f5578e4343d230f399d49fe377d8f008410974238 handle-aux-at_base.patch
+ab34509cec7419c11352094ed6acf14e5766b314bd2b96506a0d0203e61e90e85ea9a121f1fefc0d00bcba381778d579ea2c02325605344530420305fcf1a0d0 0001-fix-race-condition-in-file-locking.patch
8d3a2d5315fc56fee7da9abb8b89bb38c6046c33d154c10d168fb35bfde6b0cf9f13042a3bceee34daf091bc409d699223735dcf19f382eeee1f6be34154f26f ldconfig
062bb49fa54839010acd4af113e20f7263dde1c8a2ca359b5fb2661ef9ed9d84a0f7c3bc10c25dcfa10bb3c5a4874588dff636ac43d5dbb3d748d75400756d0b __stack_chk_fail_local.c
0d80f37b34a35e3d14b012257c50862dfeb9d2c81139ea2dfa101d981d093b009b9fa450ba27a708ac59377a48626971dfc58e20a3799084a65777a0c32cbc7d getconf.c