aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-14 15:25:51 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-14 15:25:51 +0000
commit5d641c58e759ea2f8de7197290c7410fcf12cc4c (patch)
treeb536af4f36cdec6e9ee4ce024ef8d3069aeb7d3c
parent85812ec2d5b141c966ec4065a7e3a5c425d5b76e (diff)
downloadaports-5d641c58e759ea2f8de7197290c7410fcf12cc4c.tar.bz2
aports-5d641c58e759ea2f8de7197290c7410fcf12cc4c.tar.xz
community/py-django-compressor: modernize abuild
-rw-r--r--community/py-django-compressor/APKBUILD26
1 files changed, 9 insertions, 17 deletions
diff --git a/community/py-django-compressor/APKBUILD b/community/py-django-compressor/APKBUILD
index 8721501ea8..ff12006e9f 100644
--- a/community/py-django-compressor/APKBUILD
+++ b/community/py-django-compressor/APKBUILD
@@ -1,34 +1,26 @@
# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
# Maintainer: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
pkgname=py-django-compressor
+_pkgname=django_compressor
pkgver=2.2
-pkgrel=0
+pkgrel=1
pkgdesc="JavaScript and CSS compressor for Django"
-url=https://github.com/django-compressor/django-compressor
-arch=noarch
+url="https://github.com/django-compressor/django-compressor"
+arch="noarch"
license="MIT and Apache-2.0 and BSD"
depends="py-django py-django-appconf"
-makedepends=py-setuptools
-source="https://files.pythonhosted.org/packages/source/d/django_compressor/django_compressor-$pkgver.tar.gz"
+makedepends="py-setuptools"
+source="https://files.pythonhosted.org/packages/source/d/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir=$srcdir/django_compressor-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py build
}
package() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py install --root "$pkgdir"
}