aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-07 06:57:56 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-07 06:58:01 +0000
commit5f56cc0578adef078fdce09c9d18a64ab9ff32e9 (patch)
tree4aed2044988b3491aa530b58bda3353e91390cf6
parent9160d001b49bc41cd436201eba4c527b4f1a9d8f (diff)
downloadaports-5f56cc0578adef078fdce09c9d18a64ab9ff32e9.tar.bz2
aports-5f56cc0578adef078fdce09c9d18a64ab9ff32e9.tar.xz
testing/dvdauthor: new aport
-rw-r--r--testing/dvdauthor/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/dvdauthor/APKBUILD b/testing/dvdauthor/APKBUILD
new file mode 100644
index 0000000000..0541cb5818
--- /dev/null
+++ b/testing/dvdauthor/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=dvdauthor
+pkgver=0.7.1
+pkgrel=0
+pkgdesc="DVD authoring tools"
+url="http://dvdauthor.sourceforge.net"
+arch="all"
+license="GPL"
+makedepends="libpng-dev freetype-dev libdvdread-dev
+ fribidi-dev imagemagick-dev libxml2-dev"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+builddir="$srcdir/$pkgname"
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install
+}
+
+sha512sums="0875300df4711bf5758cb8a3ec03793689abd403cdebfc5736463d9b6df49a22e66e9e1f0c2abfcb7d25469c2e7f7e76789f7779cc0743ec972f8965b0f744a9 dvdauthor-0.7.1.tar.gz"