aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-03-12 15:17:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-03-12 15:39:49 +0000
commit6494a1936832f3c3d7dad49d71eed232bea1c0a4 (patch)
treec57e3a539075ce31ef9e0b7ff9fb22b492fa244a
parentfba30f4978632d5976d9a76bac43a50a20182404 (diff)
downloadaports-6494a1936832f3c3d7dad49d71eed232bea1c0a4.tar.bz2
aports-6494a1936832f3c3d7dad49d71eed232bea1c0a4.tar.xz
testing/zfs-git-grsec: removed
shoul duse the releases instead
-rw-r--r--testing/zfs-git-grsec/APKBUILD137
-rw-r--r--testing/zfs-git-grsec/timestamp.patch16
-rw-r--r--testing/zfs-git-grsec/vdev_id_posix.patch103
3 files changed, 0 insertions, 256 deletions
diff --git a/testing/zfs-git-grsec/APKBUILD b/testing/zfs-git-grsec/APKBUILD
deleted file mode 100644
index ca16f1b0a0..0000000000
--- a/testing/zfs-git-grsec/APKBUILD
+++ /dev/null
@@ -1,137 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
-
-_flavor=${FLAVOR:-grsec}
-_realname=zfs-git
-_name=$_realname-$_flavor
-
-_kpkg=linux-$_flavor
-_kver=3.6.11
-_kpkgrel=17
-
-_mypkgrel=0
-_date=20121116
-
-# source the kernel version
-if [ -f ../../main/linux-$_flavor/APKBUILD ]; then
- . ../../main/linux-$_flavor/APKBUILD
- [ "$_kver" != "$pkgver" ] && die "$_name: Please update _kver to $pkgver"
- [ "$_kpkgrel" != "$pkgrel" ] && die "$_name: Please update _kpkgrel to $pkgrel"
-fi
-
-_kernelver=$_kver-r$_kpkgrel
-_abi_release=$_kver-${_flavor}
-
-pkgname=$_name
-pkgver=$_kver
-pkgrel=$(($_kpkgrel + $_mypkgrel))
-pkgdesc="ZFS for Linux"
-url="http://zfsonlinux.org"
-arch="x86_64"
-license="CDDL"
-depends="spl-git-$_flavor"
-depends_dev="glib-dev e2fsprogs-dev util-linux-dev
- linux-$_flavor-dev spl-git-$_flavor-dev"
-makedepends="$depends_dev automake autoconf libtool"
-install=""
-subpackages="$pkgname-dev $pkgname-doc $_realname-utils:utils"
-
-source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-${_date}.tar.gz
- timestamp.patch
- vdev_id_posix.patch"
-_giturl="git://github.com/zfsonlinux/zfs.git"
-_upload=dev.alpinelinux.org:/archive/$pkgname/
-
-_builddir="$srcdir"/$pkgname-$_date
-
-snapshot() {
- _date=$(date +%Y%m%d)
- local _pkg=$pkgname-$_date.tar.gz
- mkdir -p "$srcdir"
- cd "$srcdir"
- rm -rf "$pkgname"
- git clone --depth=1 --bare $_giturl || return 1
- git --git-dir ${_giturl##*/} archive -o $_pkg \
- --prefix=$pkgname-$_date/ HEAD \
- || return 1
- msg "New snapshot: $_pkg"
- msg "Uploading to $_upload"
- _newrel=$((_mypkgrel + 1))
- scp $_pkg $_upload || return 1
- cd ..
- sed -i -e "s/^_mypkgrel=.*/_mypkgrel=$_newrel/" \
- -e "s/^_date=.*/_date=$_date/" \
- APKBUILD || return 1
- _dir=${PWD%/APKBUILD}
- _dir=${_dir%/*}
- abuild checksum && abuild -r && git add APKBUILD \
- && git commit -m"${_dir##*/}/$pkgname: snapshot $_date"
-}
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./autogen.sh || return 1
- export LIBS="$LIBS -lintl"
- export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --with-config=all \
- --with-udevdir=/lib/udev \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm -f "$pkgdir"/usr/lib/*.la
- rm -rf "$pkgdir"/usr/libexec
- rm -rf "$pkgdir"/usr/share/dracut
-}
-
-dev() {
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/src \
- "$subpkgdir"/usr || return 1
- default_dev
-}
-
-utils() {
- pkgdesc="Userland tools to manage zfs on linux"
- depends="bash"
- mkdir -p "$subpkgdir"
- mv "$pkgdir"/* "$subpkgdir" || return 1
- mkdir -p "$pkgdir"/lib
- mv "$subpkgdir"/lib/modules \
- "$pkgdir"/lib || return 1
- rm -f "$subpkgdir"/etc/init.d/zfs
- install -m755 -D "$_builddir"/etc/init.d/zfs.gentoo.in \
- "$subpkgdir"/etc/init.d/zfs
- sed -i -e "s/@sbindir@/\/usr\/sbin/g" \
- "$subpkgdir"/etc/init.d/zfs || return 1
- sed -i -e "s/@sysconfdir@/\/etc/g" \
- "$subpkgdir"/etc/init.d/zfs || return 1
-}
-
-md5sums="b73134395b9b72a9be30c56da231d9ca zfs-git-grsec-20121116.tar.gz
-9621735b802e34d792b03ef89727f6ea timestamp.patch
-c9a5307dc254ff4ff4808a178f4d8bd6 vdev_id_posix.patch"
-sha256sums="bea2601b42bace78c148e370623fac23ae01810ab8042a53be7ee6edf3f2a481 zfs-git-grsec-20121116.tar.gz
-74924b471c2a83831f274b876c1d4f293f1e142089f34fccd19ae60b59066661 timestamp.patch
-fcb2b2e11ffb9b2f3d1a8eac3d7a797af396b8e1f7b17ae1b7934261a0afbb52 vdev_id_posix.patch"
-sha512sums="ea3371ea05e3bcc59207a6831081899536b09acb55fafd7289fde4626aa52e46cc75ebc6f3343ba857ac49536f3c926db9be45bbd37532af0ebcaa6ff99a8bf1 zfs-git-grsec-20121116.tar.gz
-2cb675e4603ea4aa951c7da2c57374bb404d52ee4fd04c719479ff07a3cf50c1d6f4b7cd2398c20327127fe81d47fcfa2ed95d18f05acd59f1ee8115334aabd2 timestamp.patch
-ab92675212071abc5f95854e985d739c344d0803d647f0e081e3d2083b9a2cafc12da4c532ed1f32ae6e48ab5677ea91f9d63009d0d6eca945aea395ae2caa0a vdev_id_posix.patch"
diff --git a/testing/zfs-git-grsec/timestamp.patch b/testing/zfs-git-grsec/timestamp.patch
deleted file mode 100644
index 68a612faaf..0000000000
--- a/testing/zfs-git-grsec/timestamp.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-uclibc does not support _DATE_FMT, it seems to be a libc only thing
-not sure this will work, will need to take a closer look.
-http://pubs.opengroup.org/onlinepubs/007904975/basedefs/langinfo.h.html
-http://sources.redhat.com/ml/libc-alpha/2000-10/msg00298.html
-
---- ./lib/libspl/timestamp.c.orig
-+++ ./lib/libspl/timestamp.c
-@@ -40,7 +40,7 @@
-
- /* We only need to retrieve this once per invocation */
- if (fmt == NULL)
-- fmt = nl_langinfo(_DATE_FMT);
-+ fmt = nl_langinfo(D_FMT);
-
- if (timestamp_fmt == UDATE) {
- (void) printf("%ld\n", t);
diff --git a/testing/zfs-git-grsec/vdev_id_posix.patch b/testing/zfs-git-grsec/vdev_id_posix.patch
deleted file mode 100644
index 8f44d039c8..0000000000
--- a/testing/zfs-git-grsec/vdev_id_posix.patch
+++ /dev/null
@@ -1,103 +0,0 @@
-From 8714d5292b09502b9f19a6f01f7d5fac99e9759c Mon Sep 17 00:00:00 2001
-From: Ned Bass <bass6@llnl.gov>
-Date: Wed, 19 Sep 2012 11:44:12 -0700
-Subject: [PATCH] Make vdev_id POSIX sh compatible
-
-Full bash may not be available in all environments where udev helpers
-run, such as in an initial ramdisk. To avoid breakage in this case,
-remove use of bash-specific features such as variable arrays and the
-`declare' keyword from the vdev_id script.
-
-Closes #870
-Signed-off-by: Ned Bass <bass6@llnl.gov>
----
- cmd/vdev_id/vdev_id | 33 ++++++++++++++++++++-------------
- 1 file changed, 20 insertions(+), 13 deletions(-)
-
-diff --git a/cmd/vdev_id/vdev_id b/cmd/vdev_id/vdev_id
-index d278197..55af515 100755
---- a/cmd/vdev_id/vdev_id
-+++ b/cmd/vdev_id/vdev_id
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
- #
- # vdev_id: udev helper to generate user-friendly names for JBOD disks
- #
-@@ -80,7 +80,6 @@ SLOT_MAP=
- CHANNEL_MAP=
- MULTIPATH=
- TOPOLOGY=
--declare -i i j
-
- usage() {
- cat << EOF
-@@ -229,32 +228,39 @@ else
- sys_path=`udevadm info -q path -p /sys/block/$DEV 2>/dev/null`
- fi
-
--dirs=(`echo "$sys_path" | tr / ' '`)
-+# Use positional parameters as an ad-hoc array
-+set -- $(echo "$sys_path" | tr / ' ')
-+num_dirs=$#
- scsi_host_dir="/sys"
-
- # Get path up to /sys/.../hostX
--for (( i=0; i<${#dirs[*]}; i++ )); do
-- d=${dirs[$i]}
-+i=1
-+while [ $i -le $num_dirs ] ; do
-+ d=$(eval echo \$$i)
- scsi_host_dir="$scsi_host_dir/$d"
- echo $d | egrep -q -e '^host[0-9]+$' && break
-+ i=$(($i + 1))
- done
-
--if [ $i = ${#dirs[*]} ] ; then
-+if [ $i = $num_dirs ] ; then
- exit 0
- fi
-
--PCI_ID=`echo ${dirs[$(( $i - 1 ))]} | awk -F: '{print $2":"$3}'`
-+PCI_ID=$(eval echo \$$(($i -1)) | awk -F: '{print $2":"$3}')
-
--# In sas_switch mode, the directory three levels beneath /sys/.../hostX
-+# In sas_switch mode, the directory four levels beneath /sys/.../hostX
- # contains symlinks to phy devices that reveal the switch port number. In
- # sas_direct mode, the phy links one directory down reveal the HBA port.
- port_dir=$scsi_host_dir
- case $TOPOLOGY in
-- "sas_switch") j=$(($i+4)) ;;
-+ "sas_switch") j=$(($i + 4)) ;;
- "sas_direct") j=$(($i + 1)) ;;
- esac
--for (( i++; i<=$j; i++ )); do
-- port_dir="$port_dir/${dirs[$i]}"
-+
-+i=$(($i + 1))
-+while [ $i -le $j ] ; do
-+ port_dir="$port_dir/$(eval echo \$$i)"
-+ i=$(($i + 1))
- done
-
- PHY=`ls -d $port_dir/phy* 2>/dev/null | head -1 | awk -F: '{print $NF}'`
-@@ -266,13 +272,14 @@ PORT=$(( $PHY / $PHYS_PER_PORT ))
- # Look in /sys/.../sas_device/end_device-X for the bay_identifier
- # attribute.
- end_device_dir=$port_dir
--for (( ; i<${#dirs[*]} ; i++ )); do
-- d=${dirs[$i]}
-+while [ $i -lt $num_dirs ] ; do
-+ d=$(eval echo \$$i)
- end_device_dir="$end_device_dir/$d"
- if echo $d | egrep -q -e '^end_device' ; then
- end_device_dir="$end_device_dir/sas_device/$d"
- break
- fi
-+ i=$(($i + 1))
- done
-
- SLOT=`cat $end_device_dir/bay_identifier 2>/dev/null`
---
-1.7.10
-