aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-05-13 12:44:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-05-13 12:44:37 +0000
commit675ac7f71d9221b6c5db430e4725cbbbab725cd1 (patch)
tree84df5b9a450644bdb967cf3fbcabf8b7a431db1e
parentc33dad369ded7a4d197417f49e54730ad84a6761 (diff)
downloadaports-675ac7f71d9221b6c5db430e4725cbbbab725cd1.tar.bz2
aports-675ac7f71d9221b6c5db430e4725cbbbab725cd1.tar.xz
main/firefox: upgrade to 38.0 (esr)
-rw-r--r--main/firefox/0002-Use-C99-math-isfinite.patch38
-rw-r--r--main/firefox/APKBUILD48
-rw-r--r--main/firefox/fix-fortify-inline.patch4
-rw-r--r--main/firefox/fix-ipc.patch11
-rw-r--r--main/firefox/fix-linux-include.patch10
-rw-r--r--main/firefox/fix-media-webrtc.patch14
-rw-r--r--main/firefox/fix-media.patch28
-rw-r--r--main/firefox/libvpx-1.4.0.patch74
8 files changed, 47 insertions, 180 deletions
diff --git a/main/firefox/0002-Use-C99-math-isfinite.patch b/main/firefox/0002-Use-C99-math-isfinite.patch
index 03f830bcae..ba4f5cfb3d 100644
--- a/main/firefox/0002-Use-C99-math-isfinite.patch
+++ b/main/firefox/0002-Use-C99-math-isfinite.patch
@@ -1,29 +1,17 @@
-From cdb9db4c1c593dbe22db4f389a62fce034f31f2d Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 25 Nov 2011 08:30:51 +0000
-Subject: [PATCH 2/4] Use C99 math isfinite
-
----
- xpcom/ds/nsMathUtils.h | 6 +++++-
- 2 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/xpcom/ds/nsMathUtils.h b/xpcom/ds/nsMathUtils.h
-index 21ffbec..2e80476 100644
---- a/xpcom/ds/nsMathUtils.h
-+++ b/xpcom/ds/nsMathUtils.h
-@@ -131,7 +131,11 @@ inline NS_HIDDEN_(bool) NS_finite(double d)
- // NOTE: '!!' casts an int to bool without spamming MSVC warning C4800.
- return !!_finite(d);
+--- ./xpcom/ds/nsMathUtils.h.orig
++++ ./xpcom/ds/nsMathUtils.h
+@@ -104,12 +104,12 @@
+ #ifdef WIN32
+ // NOTE: '!!' casts an int to bool without spamming MSVC warning C4800.
+ return !!_finite(aNum);
+-#elif defined(XP_DARWIN)
++#elif defined(XP_DARWIN) || defined(_GLIBCXX_CMATH)
+ // Darwin has deprecated |finite| and recommends |isfinite|. The former is
+ // not present in the iOS SDK.
+ return std::isfinite(aNum);
#else
-- return finite(d);
-+#ifdef _GLIBCXX_CMATH
-+ return std::isfinite(d);
-+#else
-+ return isfinite(d);
-+#endif
+- return finite(aNum);
++ return isfinite(aNum);
#endif
}
---
-1.7.7.4
-
diff --git a/main/firefox/APKBUILD b/main/firefox/APKBUILD
index 88257290ec..6137fd1440 100644
--- a/main/firefox/APKBUILD
+++ b/main/firefox/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=firefox
-pkgver=31.6.0
+pkgver=38.0
_pkgver=$pkgver
_xulver=$pkgver
-pkgrel=3
+pkgrel=0
pkgdesc="Firefox web browser"
url="https://www.mozilla.org/en-US/firefox/organizations/faq/"
arch="all"
@@ -49,7 +49,7 @@ makedepends="$depends_dev
"
install=""
-subpackages="$pkgname-dbg $pkgname-dev"
+subpackages="$pkgname-dev"
source="ftp://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.bz2
mozconfig
vendor.js
@@ -57,11 +57,11 @@ source="ftp://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-$
0002-Use-C99-math-isfinite.patch
fix-arm-atomics-grsec.patch
fix-ipc.patch
- fix-media-webrtc.patch
fix-media.patch
fix-netwerk.patch
fix-toolkit.patch
fix-tools.patch
+ fix-linux-include.patch
getchar.patch
mozilla-build-arm.patch
stat.patch
@@ -69,7 +69,6 @@ source="ftp://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-$
rhbz-966424.patch
fix-fortify-inline.patch
- libvpx-1.4.0.patch
firefox.desktop
firefox-safe.desktop"
@@ -170,63 +169,60 @@ dev() {
default_dev
}
-md5sums="7763129c3bdc393c1f3b4a917ac48ee4 firefox-31.6.0esr.source.tar.bz2
+md5sums="591f1cdf503489b872b8d30a4d9c987e firefox-38.0esr.source.tar.bz2
1f4c60e662ed93784431bd06c5141719 mozconfig
1515663477ce427cbdc42f04d8d5ca4e vendor.js
-f43c1f0ae57aa8289b130c6de8caf3ce 0002-Use-C99-math-isfinite.patch
+6ab77b80c8c7d6fd07ab53c54561f4df 0002-Use-C99-math-isfinite.patch
b18bd948aae828e5c8f5f63e440c96d6 fix-arm-atomics-grsec.patch
-38a9c0d5be155164d50a956ac131d991 fix-ipc.patch
-ce4839160acf3986a2118326ed2b8444 fix-media-webrtc.patch
-960d56439a375998ce4e4597bf245375 fix-media.patch
+0c453c2e058ac568e0148c02b1c09abd fix-ipc.patch
+f8bc97333847f37597c0bac0dca64eb2 fix-media.patch
170b8e7f8cab21f0965f226c291a57f9 fix-netwerk.patch
296954be4c6d6bfcc24d0a46a2bd7d74 fix-toolkit.patch
2279c55a85013fc1c0d01427768edd4d fix-tools.patch
+2f0b995b1313884b10e4a61c2ce2cd01 fix-linux-include.patch
507742325de8687529e4e81e31132ddf getchar.patch
308ba5b54116a035fe68d0d5c3974857 mozilla-build-arm.patch
d9a2245b93a7f5855ee029b5fa44e4e9 stat.patch
4383d038b8d8411ea46f4a109197c19e stab.h
15ebeeeb6823c185f4fed98e9bf1b786 rhbz-966424.patch
-4272fe0d076566e16daf67faee4090b0 fix-fortify-inline.patch
-8387ed2b3a908df11a96d953e60af9eb libvpx-1.4.0.patch
+f29e0036edc7b3a4158a82fa97bde500 fix-fortify-inline.patch
ba96924ece1d77453e462429037a2ce5 firefox.desktop
6f38a5899034b7786cb1f75ad42032b8 firefox-safe.desktop"
-sha256sums="88ad45202a7aee9c43378879863b023270aa29463d312f396a78a6e9cdcbf5c3 firefox-31.6.0esr.source.tar.bz2
+sha256sums="4d3f5427bfb56c992671ea1d516ac4f69375ee24cc919233527117eca6f0b42c firefox-38.0esr.source.tar.bz2
23c2b4535ce83c92ba978e15ce328c9f140def155d12523c00df30baf41b98dc mozconfig
d72ca759792cc8c88efc664d30087a139fed7fc3d7d058e4cd9ab287bb80ea46 vendor.js
-2f319883300f2aef180bfb80221151fcbb29344a5a0a086d6ad1d80005daf039 0002-Use-C99-math-isfinite.patch
+080a55182b865471a86fa4b70a66ed9495f1e536f7fdc4060cb8c675b4749c6e 0002-Use-C99-math-isfinite.patch
ff7cb3c9c4712e0517a6f11e3bf08e9b0d13dbe6384930bdc7f55b1ceed039b5 fix-arm-atomics-grsec.patch
-059a69ff0dbceeaa5bbb1446aa4233bc578a047fcad22c0efa27dc64bbd72980 fix-ipc.patch
-3e53af8beff122bcf5790c148fb51f41f44b6fe5dd5799777b70c3542c32cb93 fix-media-webrtc.patch
-d582712c28a26679d728d21d2ef8964d119182edaf580a948f57a9e808ccc5cf fix-media.patch
+fa7d50f399b6fc1ec1c007cabadc5c0cb9e1daf92c7f6ad89f651b8ce268c765 fix-ipc.patch
+c1d0fbcf5e8610df9adc66ea956753e7d495e8ed2d1c1e06d183f4680c85db97 fix-media.patch
4a2f8ff5e9b1359541eba8854098cee2caeb40ad9dbdc4b8fcf48b47ea8ca2d2 fix-netwerk.patch
666883189dba3f4c7ba6b5bc85026c85bcb84477c2d5ba00d6414ddd0f744368 fix-toolkit.patch
60ed0870119480994c6c455034c52dd21b8482b7617c3a0032e3b2abf4467e4d fix-tools.patch
+a3a6291888819e0f10e3ca05b2979093b32c723c4bf67b19ea1ab14555085236 fix-linux-include.patch
d14357bf44f702d94b8d3ed79bdf81f6271370745c1ac8fa83522bd98be4adc4 getchar.patch
6f5f5e4d2a17182b72b248e896450235ccdaf63252fdb89a8deb55da8adc9be3 mozilla-build-arm.patch
a0f8a0fa9977ee43f3853b6c6bf5a506fdfabdfa32b4279e0ac3d7a3078f34cc stat.patch
960d82bbfdc88c95f5cb4f2e1c1bf23dae7519b3b7203914d7b3ddbff1ba4c28 stab.h
a50d15a640f230a2c66e1eb2afd2bed4117605d0f1591dcfec1ca30f0bc2352f rhbz-966424.patch
-bcd8759804a52ffd542292f28d0aafc6f4f1f9408fe0f36adb9ba11fe3b85afc fix-fortify-inline.patch
-87d01a1913a5a6b93c49893ae0fe5aec81db55ebf6cc60d808a9e6eabebc6339 libvpx-1.4.0.patch
+ecf808ef1bc2920f6f7a4786fafb46c74e8a2c3bc628f28f10d6e8e1a265e609 fix-fortify-inline.patch
b571c4a49884a3c98806246c9cc3e60c73d5a8f4aeb7f96217db0be1d6210eda firefox.desktop
4b6de45753856a890f4482055666e77f9b01bdfb7e0df08bafaa3a4d9937eed3 firefox-safe.desktop"
-sha512sums="6b81059b3a38f2a264cf5bea665ad107e5439a8614644fd3a910034381ab6c0635cea50aa30bd83fec8d8cfebea76c3480eee3a96dfdcbb606c1dd62ef3880a4 firefox-31.6.0esr.source.tar.bz2
+sha512sums="21ddd42bf23991b0feadb2a2aaa3bfbd97bbc21677e5f26c45aaa9b5c4da4b1083c5b6b1900eb4d6ae7aba9e67d36dd82643061cbac15ebdc602d51300a80319 firefox-38.0esr.source.tar.bz2
e14b4a646230f7a752ef864b0e6a074fdac74d6c4abde2c31656eb10ac6f002a5c664d257bf3f4bd22544f10103e38d5fae49f84fcaae402b81940e72bcfe0e5 mozconfig
93570f821e59af4d233fc4b1df85e1d145a5e041ad402fd72921987a5a2f5218538d7a13d59bbf0bda5e7df1d5281407674a3765625936340106d1185b15b5d8 vendor.js
-9a6666a3b637549411ea562c9d0d6d617ed48327d0f9e4e64d27f43774c218e6c5cf5fa99d4b339a5a0f89b854a18079392eba0dafc3419adbd4cdd5d71d3f26 0002-Use-C99-math-isfinite.patch
+7e123144bc2b1efed149dfb41b255c447d43ea93a63ebe114d01945e6a6d69edc2f2a3c36980a93279106c1842355851b8b6c1d96679ee6be7b9b30513e0b1a8 0002-Use-C99-math-isfinite.patch
4311464ae52b6d2e2b02c789c6d5fca9b3c211888a983aa609a62c2f2554516fea735ea90673387c69b38a30aa8453ed79faa44b5163df4293880d40df676b2d fix-arm-atomics-grsec.patch
-3f360d4231355c268fc52e0fedbce5c4f73ad8d60d9424af8641733c0ae181e6226056e605f0d6653b729a9c8e4abe97a9fb2face25938651a7498d5753cea8b fix-ipc.patch
-a5d00272fc9e2b3a786f5891bac11b04ffaf6dfcbd2b30cba42286b79d12fefb6cb9c81e6d75987ab3ee19d12af20a074c77edc655bd470be06f5025eb38e609 fix-media-webrtc.patch
-58e0e7c1c368530b58aa143be0403d733c4b82cc1a9964c925278e5eff147b2ec2c8c34a6cb217387cb7e9f2ca13c2e299745015edaac510704963282dc68e79 fix-media.patch
+6419b3ec12c775c8bbce2c5737e68bb6c93f5b6c69af65b4fbbc525de3e2022def61943ab713c278aff9a6c27c1df1e19fb94940a755a94f6b40fd0492fae228 fix-ipc.patch
+f4d1b0814247cdfe1655a0f345def4f80bd66f37ae5b0edc2cd6b8358e39e9a1bcc0a4ed7d1c4074a1302fb027a2f8be549225c5f4f56caf2513c968ed05d666 fix-media.patch
8a896ee4d1465a844351cec84217de1a28b9f27bfc1e34cc71368664b5b8804bd66bdcadc78c78ee365abd1d0cafed1e6c568045c93cb78ac94e2818f503d58c fix-netwerk.patch
72459754016f254c58d56d9a8719897fa8da9cf969eaa498e1e755457942d3f0ac56e4abd3f6a66ef924c94aa034d0af18a1fb653926b2496f0c2615fdb24c5e fix-toolkit.patch
426b57ce698de3eecd1b52f2998974c4e0b5922584b09b554d436c61fee039d1f86345e746fee067801ebbf50815c4d19b96266a2ed72a35ae5c3edbdb57bba1 fix-tools.patch
+2c3319fd625c5d183e310ce6a27ec35e91caafd2206b7b992a539924f9bdb001b0340f1f4451650d4d968134ad35ba1f955cacfff10cb58980f27c42c90d280d fix-linux-include.patch
18f0696bf4d032c83041110b83ae6531b48474a778fc1deade3b06ba2ae1bfcc9891059287bfb78317c2f5ddc88f5b7ce957312acdb63d4902a57e0b40eb6520 getchar.patch
e61664bc93eadce5016a06a4d0684b34a05074f1815e88ef2613380d7b369c6fd305fb34f83b5eb18b9e3138273ea8ddcfdcb1084fdcaa922a1e5b30146a3b18 mozilla-build-arm.patch
1a8754830dbbf5432a611504c957c4ff24fdc31dc1a5ee7cdd4240bc5c084baa26a24f18527ff398ec81e56a36aee31732138243cf22a6bab89703656ff463e7 stat.patch
0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
06ededcd196af98b77991dcba3b710b0dfc061404adb4676fcc380be80410a2621f64d67257b0aefdf36f566e0ea1294b5405b7b4db43e83281a1c64d02da579 rhbz-966424.patch
-0f7a6b71dd25048b353cafa8147b56a90e0c324e78a721ea4c0777bd6c193a985591b936209f026bc3aa6f64f8b749a27a212c51754af48f8f237bd7eb59faa2 fix-fortify-inline.patch
-a439299bca2f3e5e21aeffa3ef08d9bf2683ed7afe335c799c0cc07e36049d96c7c86563d9e8cbfd079ba33fc263ef4b5faadefcf9fe992cfffe066e7eb7bfe5 libvpx-1.4.0.patch
+09bc32cf9ee81b9cc6bb58ddbc66e6cc5c344badff8de3435cde5848e5a451e0172153231db85c2385ff05b5d9c20760cb18e4138dfc99060a9e960de2befbd5 fix-fortify-inline.patch
f3b7c3e804ce04731012a46cb9e9a6b0769e3772aef9c0a4a8c7520b030fdf6cd703d5e9ff49275f14b7d738fe82a0a4fde3bc3219dff7225d5db0e274987454 firefox.desktop
5dcb6288d0444a8a471d669bbaf61cdb1433663eff38b72ee5e980843f5fc07d0d60c91627a2c1159215d0ad77ae3f115dcc5fdfe87e64ca704b641aceaa44ed firefox-safe.desktop"
diff --git a/main/firefox/fix-fortify-inline.patch b/main/firefox/fix-fortify-inline.patch
index 61af42ed62..2498c57fc7 100644
--- a/main/firefox/fix-fortify-inline.patch
+++ b/main/firefox/fix-fortify-inline.patch
@@ -1,5 +1,5 @@
---- a/media/webrtc/signaling/src/sipcc/core/sdp/sdp_os_defs.h
-+++ b/media/webrtc/signaling/src/sipcc/core/sdp/sdp_os_defs.h
+--- a/media/webrtc/signaling/src/sdp/sipcc/sdp_os_defs.h
++++ b/media/webrtc/signaling/src/sdp/sipcc/sdp_os_defs.h
@@ -27,8 +27,5 @@
typedef int16_t int16;
typedef unsigned short ushort;
diff --git a/main/firefox/fix-ipc.patch b/main/firefox/fix-ipc.patch
index e21d57f40d..8371957d4b 100644
--- a/main/firefox/fix-ipc.patch
+++ b/main/firefox/fix-ipc.patch
@@ -1,14 +1,3 @@
---- mozilla-release.orig/ipc/chromium/src/base/debug_util_posix.cc
-+++ mozilla-release/ipc/chromium/src/base/debug_util_posix.cc
-@@ -5,7 +5,7 @@
- #include "build/build_config.h"
- #include "base/debug_util.h"
-
--#define MOZ_HAVE_EXECINFO_H (defined(OS_LINUX) && !defined(ANDROID))
-+#define MOZ_HAVE_EXECINFO_H (defined(OS_LINUX) && defined(__GLIBC__))
-
- #include <errno.h>
- #include <fcntl.h>
--- mozilla-release.orig/ipc/chromium/src/base/file_util.h
+++ mozilla-release/ipc/chromium/src/base/file_util.h
@@ -14,10 +14,15 @@
diff --git a/main/firefox/fix-linux-include.patch b/main/firefox/fix-linux-include.patch
new file mode 100644
index 0000000000..d625557cf9
--- /dev/null
+++ b/main/firefox/fix-linux-include.patch
@@ -0,0 +1,10 @@
+--- ./xpcom/io/nsLocalFileUnix.cpp.orig
++++ ./xpcom/io/nsLocalFileUnix.cpp
+@@ -28,6 +28,7 @@
+ #define USE_LINUX_QUOTACTL
+ #include <sys/mount.h>
+ #include <sys/quota.h>
++#include <linux/fs.h>
+ #endif
+
+ #include "xpcom-private.h"
diff --git a/main/firefox/fix-media-webrtc.patch b/main/firefox/fix-media-webrtc.patch
deleted file mode 100644
index a173d795dd..0000000000
--- a/main/firefox/fix-media-webrtc.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://bugzilla.mozilla.org/show_bug.cgi?id=1010194
-
-diff -ru mozilla-release/media.orig/webrtc/signaling/src/sipcc/cpr/include/cpr_threads.h mozilla-release/media/webrtc/signaling/src/sipcc/cpr/include/cpr_threads.h
---- mozilla-release/media.orig/webrtc/signaling/src/sipcc/cpr/include/cpr_threads.h 2014-05-07 01:56:10.000000000 -0300
-+++ mozilla-release/media/webrtc/signaling/src/sipcc/cpr/include/cpr_threads.h 2014-05-14 14:56:45.938648384 -0300
-@@ -30,7 +30,7 @@
- uint32_t threadId;
- union {
- void *handlePtr;
-- uint64_t handleInt;
-+ unsigned long handleInt;
- } u;
- } cpr_thread_t;
-
diff --git a/main/firefox/fix-media.patch b/main/firefox/fix-media.patch
index a016a48753..af6045fe72 100644
--- a/main/firefox/fix-media.patch
+++ b/main/firefox/fix-media.patch
@@ -8,31 +8,3 @@
#include <sys/syslog.h>
#else
#include <syslog.h>
-@@ -53,7 +52,6 @@
- #undef __unused
- #include <linux/sysctl.h>
- #endif
--#include <net/if.h>
- #ifndef LINUX
- #if !defined(__OpenBSD__) && !defined(__NetBSD__)
- #include <net/if_var.h>
-@@ -63,8 +61,8 @@
- #include <sys/sockio.h>
- #else
- #include <linux/sockios.h>
--#include <linux/if.h>
- #include <linux/kernel.h>
-+#include <linux/if.h>
- #include <linux/wireless.h>
- #ifndef ANDROID
- #include <linux/ethtool.h>
---- mozilla-release/media.orig/mtransport/third_party/nICEr/src/stun/stun.h
-+++ mozilla-release/media/mtransport/third_party/nICEr/src/stun/stun.h
-@@ -39,7 +39,6 @@
- #else
- #include <sys/param.h>
- #include <sys/socket.h>
--#include <net/if.h>
- #ifndef LINUX
- #if !defined(__OpenBSD__) && !defined(__NetBSD__)
- #include <net/if_var.h>
diff --git a/main/firefox/libvpx-1.4.0.patch b/main/firefox/libvpx-1.4.0.patch
deleted file mode 100644
index 9d393cc17f..0000000000
--- a/main/firefox/libvpx-1.4.0.patch
+++ /dev/null
@@ -1,74 +0,0 @@
---- ./media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc.orig
-+++ ./media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc
-@@ -180,7 +180,7 @@
- // Creating a wrapper to the image - setting image data to NULL. Actual
- // pointer will be set in encode. Setting align to 1, as it is meaningless
- // (actual memory is not allocated).
-- raw_ = vpx_img_wrap(NULL, IMG_FMT_I420, codec_.width, codec_.height,
-+ raw_ = vpx_img_wrap(NULL, VPX_IMG_FMT_I420, codec_.width, codec_.height,
- 1, NULL);
- // populate encoder configuration with default values
- if (vpx_codec_enc_config_default(vpx_codec_vp8_cx(), config_, 0)) {
-@@ -349,9 +349,9 @@
- }
- // Image in vpx_image_t format.
- // Input image is const. VP8's raw image is not defined as const.
-- raw_->planes[PLANE_Y] = const_cast<uint8_t*>(input_image.buffer(kYPlane));
-- raw_->planes[PLANE_U] = const_cast<uint8_t*>(input_image.buffer(kUPlane));
-- raw_->planes[PLANE_V] = const_cast<uint8_t*>(input_image.buffer(kVPlane));
-+ raw_->planes[VPX_PLANE_Y] = const_cast<uint8_t*>(input_image.buffer(kYPlane));
-+ raw_->planes[VPX_PLANE_U] = const_cast<uint8_t*>(input_image.buffer(kUPlane));
-+ raw_->planes[VPX_PLANE_V] = const_cast<uint8_t*>(input_image.buffer(kVPlane));
- // TODO(mikhal): Stride should be set in initialization.
- raw_->stride[VPX_PLANE_Y] = input_image.stride(kYPlane);
- raw_->stride[VPX_PLANE_U] = input_image.stride(kUPlane);
---- ./content/media/encoder/VP8TrackEncoder.cpp.orig
-+++ ./content/media/encoder/VP8TrackEncoder.cpp
-@@ -84,7 +84,7 @@
- // Creating a wrapper to the image - setting image data to NULL. Actual
- // pointer will be set in encode. Setting align to 1, as it is meaningless
- // (actual memory is not allocated).
-- vpx_img_wrap(mVPXImageWrapper, IMG_FMT_I420,
-+ vpx_img_wrap(mVPXImageWrapper, VPX_IMG_FMT_I420,
- mFrameWidth, mFrameHeight, 1, nullptr);
-
- config.g_w = mFrameWidth;
-@@ -239,9 +239,9 @@
- uint8_t *cb = mMuteFrame.Elements() + yPlaneSize;
- uint8_t *cr = mMuteFrame.Elements() + yPlaneSize + uvPlaneSize;
-
-- mVPXImageWrapper->planes[PLANE_Y] = y;
-- mVPXImageWrapper->planes[PLANE_U] = cb;
-- mVPXImageWrapper->planes[PLANE_V] = cr;
-+ mVPXImageWrapper->planes[VPX_PLANE_Y] = y;
-+ mVPXImageWrapper->planes[VPX_PLANE_U] = cb;
-+ mVPXImageWrapper->planes[VPX_PLANE_V] = cr;
- mVPXImageWrapper->stride[VPX_PLANE_Y] = mFrameWidth;
- mVPXImageWrapper->stride[VPX_PLANE_U] = halfWidth;
- mVPXImageWrapper->stride[VPX_PLANE_V] = halfWidth;
-@@ -297,9 +297,9 @@
- const PlanarYCbCrImage::Data *data = yuv->GetData();
-
- if (isYUV420(data) && !data->mCbSkip) { // 420 planar
-- mVPXImageWrapper->planes[PLANE_Y] = data->mYChannel;
-- mVPXImageWrapper->planes[PLANE_U] = data->mCbChannel;
-- mVPXImageWrapper->planes[PLANE_V] = data->mCrChannel;
-+ mVPXImageWrapper->planes[VPX_PLANE_Y] = data->mYChannel;
-+ mVPXImageWrapper->planes[VPX_PLANE_U] = data->mCbChannel;
-+ mVPXImageWrapper->planes[VPX_PLANE_V] = data->mCrChannel;
- mVPXImageWrapper->stride[VPX_PLANE_Y] = data->mYStride;
- mVPXImageWrapper->stride[VPX_PLANE_U] = data->mCbCrStride;
- mVPXImageWrapper->stride[VPX_PLANE_V] = data->mCbCrStride;
-@@ -355,9 +355,9 @@
- return NS_ERROR_NOT_IMPLEMENTED;
- }
-
-- mVPXImageWrapper->planes[PLANE_Y] = y;
-- mVPXImageWrapper->planes[PLANE_U] = cb;
-- mVPXImageWrapper->planes[PLANE_V] = cr;
-+ mVPXImageWrapper->planes[VPX_PLANE_Y] = y;
-+ mVPXImageWrapper->planes[VPX_PLANE_U] = cb;
-+ mVPXImageWrapper->planes[VPX_PLANE_V] = cr;
- mVPXImageWrapper->stride[VPX_PLANE_Y] = mFrameWidth;
- mVPXImageWrapper->stride[VPX_PLANE_U] = halfWidth;
- mVPXImageWrapper->stride[VPX_PLANE_V] = halfWidth;