aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-04-08 16:29:46 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-04-08 16:30:02 +0000
commit9674a6492ddd1acc695f1b315f7405121ab6fc7c (patch)
tree36cc318e0edb0c210c341b4c37495d66d6968d91
parentf7b39d5f6ce952a66aac3b1375c336b20a99e054 (diff)
downloadaports-9674a6492d.tar.bz2
aports-9674a6492d.tar.xz
main/abuild: add support for lzip source packages
-rw-r--r--main/abuild/0001-abuild-Add-support-for-lzip-source-packages.patch32
-rw-r--r--main/abuild/APKBUILD5
2 files changed, 35 insertions, 2 deletions
diff --git a/main/abuild/0001-abuild-Add-support-for-lzip-source-packages.patch b/main/abuild/0001-abuild-Add-support-for-lzip-source-packages.patch
new file mode 100644
index 0000000000..532b3bd0d6
--- /dev/null
+++ b/main/abuild/0001-abuild-Add-support-for-lzip-source-packages.patch
@@ -0,0 +1,32 @@
+From 5b7b1f80cbaa88849e2698d67bf2d72ac9addac4 Mon Sep 17 00:00:00 2001
+From: Breno Leitao <breno.leitao@gmail.com>
+Date: Wed, 5 Apr 2017 13:28:07 +0000
+Subject: [PATCH] abuild: Add support for lzip source packages
+
+Currently abuild does not understand .tar.lz packages, which blocks
+the inclusion of certain packages in Alpine Linux.
+
+I found this issue when adding 'ed' package to the repository. With
+this change, abuild package will now depend on lzip package. I might
+send a patch for abuild's APKBUILD.
+---
+ abuild.in | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/abuild.in b/abuild.in
+index c201eb2..843baab 100644
+--- a/abuild.in
++++ b/abuild.in
+@@ -418,6 +418,9 @@ default_unpack() {
+ *.tar.bz2)
+ msg "Unpacking $s..."
+ tar -C "$srcdir" -jxf "$s" || return 1;;
++ *.tar.lz)
++ msg "Unpacking $s..."
++ tar -C "$srcdir" --lzip -xf "$s" || return 1;;
+ *.tar.lzma)
+ msg "Unpacking $s..."
+ unlzma -c "$s" | tar -C "$srcdir" -x \
+--
+2.12.2
+
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 14ef16b08d..bfd7890a91 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,13 +2,13 @@
pkgname=abuild
pkgver=3.0.0_rc2
_ver=${pkgver%_git*}
-pkgrel=3
+pkgrel=4
pkgdesc="Script to build Alpine Packages"
url="http://git.alpinelinux.org/cgit/abuild/"
arch="all"
license="GPL2"
depends="fakeroot sudo pax-utils libressl apk-tools>=2.0.7-r1 libc-utils
- attr tar pkgconf patch"
+ attr tar pkgconf patch lzip"
if [ "$CBUILD" = "$CHOST" ]; then
depends="$depends curl"
fi
@@ -23,6 +23,7 @@ source="http://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
0001-abuild-use-new-PKG_CONFIG_MAXIMUM_TRAVERSE_DEPTH-env.patch
0001-abuild-wrap-check-with-fakeroot.patch
0001-abuild-set-e-fix-for-update_config_-sub-guess.patch
+ 0001-abuild-Add-support-for-lzip-source-packages.patch
"
builddir="$srcdir/$pkgname-$_ver"