aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-26 19:10:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-26 20:09:58 +0000
commit976c5da194eec8b2301ffdeb9f721e15cfb81ed4 (patch)
tree7ea8260cd1be7114697a6f8a6f29e04d74c79410
parent285a4b5d5f8f2246b4edb4d5269123d3f5fb1ff3 (diff)
downloadaports-976c5da194eec8b2301ffdeb9f721e15cfb81ed4.tar.bz2
aports-976c5da194eec8b2301ffdeb9f721e15cfb81ed4.tar.xz
main/perl-text-autoformat: upgrade to 1.74 and modernize
-rw-r--r--main/perl-text-autoformat/APKBUILD36
1 files changed, 15 insertions, 21 deletions
diff --git a/main/perl-text-autoformat/APKBUILD b/main/perl-text-autoformat/APKBUILD
index aa873843d5..dafe9c7c58 100644
--- a/main/perl-text-autoformat/APKBUILD
+++ b/main/perl-text-autoformat/APKBUILD
@@ -1,7 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-text-autoformat
-pkgver=1.669004
+_pkgname=Text-Autoformat
+pkgver=1.74
pkgrel=0
pkgdesc="Text::Autoformat perl module"
url="http://search.cpan.org/dist/Text-Autoformat/"
@@ -9,33 +10,26 @@ arch="noarch"
license="GPL-2.0 or Artistic"
depends="perl perl-text-reform"
makedepends="perl-dev"
-install=""
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/D/DC/DCONWAY/Text-Autoformat-$pkgver.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/N/NE/NEILB/$_pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/Text-Autoformat-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make && make test || return 1
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="7a7881ca625fa71e551c1f43910f2865 Text-Autoformat-1.669004.tar.gz"
-sha256sums="27a0d5f7f4665906c25c3f19e84575bff06c9bcc3c217410b600ec0675322a54 Text-Autoformat-1.669004.tar.gz"
-sha512sums="7a46d32580fc4154a1a5771cb95bf9f1bae8063ab22fc63e4baf00d29693873b305cc14b825a74c7154c3347ba5167f021499cb70000924546b909c5bc741dac Text-Autoformat-1.669004.tar.gz"
+sha512sums="276e97a0db20032919a6aeacba701350fa8fadf6c1bda7dcda714ef4f1c168b8cc3150a126719d940194c8b20dd534543ec914f03c50e27e4a61b1083ca312c6 Text-Autoformat-1.74.tar.gz"