aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard J. M. Gruen <bernhard.gruen@googlemail.com>2018-03-05 15:01:10 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-04-05 16:36:41 +0200
commit9d98b12745eeb0cc885b685ca215ccc63b4dd7c3 (patch)
treee4024bf4a3063d1d766d3a0d1a4fda81aee4c82c
parent787920a93ba9ed8744c3a8524e012682c40da8f0 (diff)
downloadaports-9d98b12745eeb0cc885b685ca215ccc63b4dd7c3.tar.bz2
aports-9d98b12745eeb0cc885b685ca215ccc63b4dd7c3.tar.xz
testing/burp: upgrade to 2.1.32, fix libressl dependency and runscript
Change in runscript: It has to use the default configuration. With 2.1.x this is the only correct way to call the status page. Older versions needed the config file.
-rw-r--r--testing/burp/APKBUILD11
-rw-r--r--testing/burp/burp.init2
2 files changed, 7 insertions, 6 deletions
diff --git a/testing/burp/APKBUILD b/testing/burp/APKBUILD
index b42bcf608b..9695b5b02a 100644
--- a/testing/burp/APKBUILD
+++ b/testing/burp/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bernhard J. M. Gruen <bernhard.gruen@googlemail.com>
pkgname=burp
-pkgver=2.1.30
-pkgrel=2
+pkgver=2.1.32
+pkgrel=0
pkgdesc="A network backup and restore program"
url="http://burp.grke.org"
arch="all"
@@ -15,6 +15,7 @@ makedepends="
automake
autoconf
"
+depends=""
checkdepends="
check-dev
"
@@ -68,7 +69,7 @@ server() {
pkgdesc="$pkgdesc (server configuration and helper scripts)"
# bash is needed on the server to run burp_ca, timer and notify scripts
# I am working on a version that does not need bash anymore
- depends="bash"
+ depends="bash libressl"
cd "$builddir"
@@ -93,5 +94,5 @@ server() {
done
}
-sha512sums="8a6f8a97ee1ccaef68897be1a667b4320767718dcc7697fc16549adbc207d1c36c721df43434df3add65868d0a310cfe379432272514085125887b8257b13f22 2.1.30.zip
-13761c30315d1c647906b91efdc730ae573c3598b7429acc77f5d9e6b31458307b2553e1ef1b317a84c14205a2262af3d896e2674b3524b99cb5b463756a712b burp.init"
+sha512sums="99d1af3673f2c2f9f2315fcb920aeb22b050390ef1b5b773dd5c6316c43a05dab43563a42eef6ee68608cf048c90d3cb2f3d3bde74acf64defeb6d311a4ea256 2.1.32.zip
+ef98c1fb938063fee35cc5ae5ff9179a759b89b3c2629320ff4dffb4c42395cac1ad6b4615c6c1f34cc4be3ce54397b00f583ba5f3cd2fe8498902d4d9445e8f burp.init"
diff --git a/testing/burp/burp.init b/testing/burp/burp.init
index 4421b4e01d..2cba7dfaa1 100644
--- a/testing/burp/burp.init
+++ b/testing/burp/burp.init
@@ -27,5 +27,5 @@ reload() {
}
mon() {
- $command -c "$cfgfile" -a S
+ $command -a S
}