aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-06-06 11:22:24 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-06-06 11:25:00 +0000
commitb16eebd29fee299aa614bd931310afa368ebc25e (patch)
tree7aa2cb7dc4a4fc5a27648f7b35dda6d8d5399308
parent2db57fe7032b62e2885ec88d8b4a0b3091ebc9d2 (diff)
downloadaports-b16eebd29fee299aa614bd931310afa368ebc25e.tar.bz2
aports-b16eebd29fee299aa614bd931310afa368ebc25e.tar.xz
testing/py-pyphen: upgrade to 0.9.4 and modernize
-rw-r--r--testing/py-pyphen/APKBUILD29
1 files changed, 8 insertions, 21 deletions
diff --git a/testing/py-pyphen/APKBUILD b/testing/py-pyphen/APKBUILD
index d5a5e79e2a..6309fcca94 100644
--- a/testing/py-pyphen/APKBUILD
+++ b/testing/py-pyphen/APKBUILD
@@ -1,40 +1,27 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=py-pyphen
-pkgver=0.8
+_pkgname=Pyphen
+pkgver=0.9.4
pkgrel=0
pkgdesc="python-based dictionary hyphenator library"
url="http://www.pyphen.org/"
arch="noarch"
license="GPL-2.0-or-later MPL LGPL-2.0-or-later"
depends="python2"
-depends_dev=""
makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/P/Pyphen/Pyphen-$pkgver.tar.gz"
-_builddir="$srcdir"/Pyphen-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="eeb03180bbb6f65f98a16118341ee454 Pyphen-0.8.tar.gz"
-sha256sums="378169ce89b8d3b6a0b95bbfdedc9da8c428d6b7c98ff6498ff41c390702a21a Pyphen-0.8.tar.gz"
-sha512sums="230ae11fa3aabba52c923a562284cbc9051c42aa8bc6336bf7e66a47db8974adb3fe136f605bac4cb8c5dee20e68181e6fb3b0c5726a35ab85d11ac5e30c537a Pyphen-0.8.tar.gz"
+sha512sums="b48dcf02c5cdf5d7ee6d6968644958af9f31fba046612016d9ae1b8cfe44d438fe769592961f93f3342cc3f3af2dfc6cd40bbfe1be67e59de9a352c33f102917 Pyphen-0.9.4.tar.gz"