aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-05-13 01:23:26 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-13 01:24:58 +0200
commitb9258bf420e7303f396cc4bc3e664158806ce52f (patch)
tree14f32366856835ee7c2720c0a6c92cc21a2f4051
parent0891a808441e1ff7f1bdc0b7b1fe6fabecebf790 (diff)
downloadaports-b9258bf420e7303f396cc4bc3e664158806ce52f.tar.bz2
aports-b9258bf420e7303f396cc4bc3e664158806ce52f.tar.xz
main/nodejs: add very basic check
-rw-r--r--main/nodejs/APKBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/main/nodejs/APKBUILD b/main/nodejs/APKBUILD
index cd62578832..db2f0af2a8 100644
--- a/main/nodejs/APKBUILD
+++ b/main/nodejs/APKBUILD
@@ -49,13 +49,25 @@ build() {
make -C out mksnapshot BUILDTYPE=Release \
&& paxmark -m out/Release/mksnapshot \
&& make || return 1
+
+ # paxmark so JIT works
+ paxmark -m out/Release/node
+}
+
+# TODO Run provided test suite.
+check() {
+ cd "$builddir"/out/Release
+
+ ./node -e 'console.log("Hello, world!")'
+ ./node -e "require('assert').equal(process.versions.node, '$pkgver')"
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
- # paxmark so JIT works
+
+ # It's strange, but it really needs to be paxmarked again...
paxmark -m "$pkgdir"/usr/bin/node || return 1
cp -pr "$pkgdir"/usr/lib/node_modules/npm/man "$pkgdir"/usr/share || return 1