aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-03-26 20:15:10 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2016-03-30 08:19:18 +0000
commitbf59660fd9bd159f9267fa12ef1314cfe82208a0 (patch)
treec65ce7d126c9cb245be1d68d598ba248c88327ea
parent8ec11477c977576344be65459dd03b9255299617 (diff)
downloadaports-bf59660fd9bd159f9267fa12ef1314cfe82208a0.tar.bz2
aports-bf59660fd9bd159f9267fa12ef1314cfe82208a0.tar.xz
testing/py-pyldap: new abuild
https://github.com/pyldap/pyldap Python modules for implementing LDAP clients
-rw-r--r--testing/py-pyldap/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py-pyldap/APKBUILD b/testing/py-pyldap/APKBUILD
new file mode 100644
index 0000000000..0edd55a02b
--- /dev/null
+++ b/testing/py-pyldap/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py-pyldap
+_pkgname=${pkgname/py-/}
+pkgver=2.4.25.1
+_vermajor=${pkgver%%.*}
+_verminor=${pkgver#*.}; _verminor=${_verminor%%.*}
+pkgrel=0
+pkgdesc="Python modules for implementing LDAP clients"
+url="https://github.com/pyldap/pyldap"
+arch="all"
+license="PSF"
+depends="python libldap>=$_vermajor.$_verminor"
+makedepends="python-dev openldap-dev>=$_vermajor.$_verminor"
+source="https://github.com/$_pkgname/$_pkgname/archive/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgname-$_pkgname-$pkgver"
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="f64a5506ef98c433bb9e72f3fa073db8 pyldap-2.4.25.1.tar.gz"
+sha256sums="746389c33af6ad62c9f09b06fade2c9fe86842892d63922dbd7b164a9120ff06 pyldap-2.4.25.1.tar.gz"
+sha512sums="9b56793dcf10a9e7fe7161460f69388fd9574e34474f559bf42956689e7d218f1670416a607c0a596a6a0a9d450b719ba1643d6a6629ca70113b5b3048250dc4 pyldap-2.4.25.1.tar.gz"