aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-10-01 10:13:05 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-01 10:13:41 +0200
commitf0af06ef1fa957b31ac762bfbcb88339df178fa0 (patch)
treee4b757171858ad9ffaf37d90ec3124fef0b54667
parentfe89259459e7cda0e910589eb8491dcf4459e8df (diff)
downloadaports-f0af06ef1fa957b31ac762bfbcb88339df178fa0.tar.bz2
aports-f0af06ef1fa957b31ac762bfbcb88339df178fa0.tar.xz
testing/dia: upgrade to 0.97.3
-rw-r--r--testing/dia/APKBUILD16
-rw-r--r--testing/dia/dia-noglib.patch37
-rw-r--r--testing/dia/isfinite.patch142
3 files changed, 9 insertions, 186 deletions
diff --git a/testing/dia/APKBUILD b/testing/dia/APKBUILD
index dc70f67c40..a01b3daec3 100644
--- a/testing/dia/APKBUILD
+++ b/testing/dia/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dia
-pkgver=0.97.2
-pkgrel=2
+pkgver=0.97.3
+pkgrel=0
pkgdesc="a GTK+ based diagram creation program"
url="http://live.gnome.org/Dia"
arch="all"
@@ -13,8 +13,6 @@ install=""
subpackages="$pkgname-doc $pkgname-lang"
source="http://ftp.gnome.org/pub/gnome/sources/dia/${pkgver%.*}/dia-$pkgver.tar.xz
isinf.patch
- isfinite.patch
- dia-noglib.patch
dia-unregister-import.patch
"
@@ -45,8 +43,12 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="1e1180a513fb567709b09bc19f12105e dia-0.97.2.tar.xz
+md5sums="0e744a0f6a6c4cb6a089e4d955392c3c dia-0.97.3.tar.xz
cbbc32d417297b855353f86b484b369b isinf.patch
-eda8e89483e97473d983b048f834861a isfinite.patch
-74ac2916d6e30cad4b2843a86ee2faad dia-noglib.patch
888dd98e05d657e27842acdb0d91d73b dia-unregister-import.patch"
+sha256sums="22914e48ef48f894bb5143c5efc3d01ab96e0a0cde80de11058d3b4301377d34 dia-0.97.3.tar.xz
+cd4073083a9e09657e5444275a710c4bb1ffc9f621fc639369fb96118a184a5e isinf.patch
+30b6e23e140f637bcf94bf734e731bfdbfb4a50f6cdb0760dc9d1b37f9b5a99a dia-unregister-import.patch"
+sha512sums="34298980be930b87cb4a636344e4cb2a7e43eedc00b0969a5e446cee9b74b616fdc8c798efcb9a5832b98741f2e20632a44037b2bcb436f59591d531ef441efa dia-0.97.3.tar.xz
+cfa8fd8fecc7f0e3da185b512c169b156363a73c151547725f964e1cf7b1a305e44c493d0490c680c5f25859acee74fe4ef942ae9ee634b370bd9b9952186c5a isinf.patch
+24267507ff08ac589ec1015e55637586a9fd97802893a77849d1e7bce67135fbd3d55611e2c80be1d5f87b92406c95cd5fe484175037297ebe1dbc8eb509a7d4 dia-unregister-import.patch"
diff --git a/testing/dia/dia-noglib.patch b/testing/dia/dia-noglib.patch
deleted file mode 100644
index d91477a978..0000000000
--- a/testing/dia/dia-noglib.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- ./objects/custom/shape_typeinfo.c.orig 2011-12-08 12:41:12.136625698 +0000
-+++ ./objects/custom/shape_typeinfo.c 2011-12-08 12:41:44.584639234 +0000
-@@ -27,8 +27,7 @@
- #include "custom_util.h"
- #include <string.h>
- #include <stdarg.h>
--#include <glib/gstrfuncs.h>
--#include <glib/gstdio.h>
-+#include <glib.h>
- #include <libxml/parser.h>
-
- /*
---- ./tests/test-boundingbox.c.orig 2012-02-25 20:05:15.571090400 -0600
-+++ ./tests/test-boundingbox.c 2012-02-25 20:07:28.884033790 -0600
-@@ -28,9 +28,6 @@
- #include <glib.h>
- #include <glib-object.h>
-
--#if GLIB_CHECK_VERSION(2,16,0)
--#include <glib/gtestutils.h>
--#endif
- #include "dialib.h"
-
- /*
---- ./tests/test-objects.c.orig 2012-02-25 20:08:16.230051224 -0600
-+++ ./tests/test-objects.c 2012-02-25 20:08:31.849036318 -0600
-@@ -28,10 +28,6 @@
- #include <glib.h>
- #include <glib-object.h>
-
--#if GLIB_CHECK_VERSION(2,16,0)
--#include <glib/gtestutils.h>
--#endif
--
- #include "object.h"
- #include "plug-ins.h"
- #include "dialib.h"
diff --git a/testing/dia/isfinite.patch b/testing/dia/isfinite.patch
deleted file mode 100644
index 173b00046a..0000000000
--- a/testing/dia/isfinite.patch
+++ /dev/null
@@ -1,142 +0,0 @@
-diff --git a/lib/arrows.c b/lib/arrows.c
-index 4371946..5b6cd3a 100644
---- a/lib/arrows.c
-+++ b/lib/arrows.c
-@@ -18,7 +18,7 @@
-
- #include <config.h>
-
--#define _BSD_SOURCE 1 /* to get finite */
-+#define _GNU_SOURCE 1 /* to get isfinite */
- #include <math.h>
- #include <stdio.h>
- #include <string.h>
-@@ -29,11 +29,7 @@
-
- #ifdef G_OS_WIN32
- #include <float.h>
--#define finite(d) _finite(d)
--#endif
--
--#ifdef __EMX__
--#define finite(d) isfinite(d)
-+#define isfinite(d) _finite(d)
- #endif
-
- #include "arrows.h"
-@@ -421,7 +417,7 @@ draw_one_exactly(DiaRenderer *renderer, Point *to, Point *from,
- else {
- vl.x = 1.0; vl.y = 0.0;
- }
-- if (!finite(vl.x)) {
-+ if (!isfinite(vl.x)) {
- vl.x = 1.0; vl.y = 0.0;
- }
- point_get_perp(&vt,&vl);
-@@ -498,7 +494,7 @@ draw_one_or_none(DiaRenderer *renderer, Point *to, Point *from,
- else {
- vl.x = 1.0; vl.y = 0.0;
- }
-- if (!finite(vl.x)) {
-+ if (!isfinite(vl.x)) {
- vl.x = 1.0; vl.y = 0.0;
- }
- point_get_perp(&vt,&vl);
-@@ -610,7 +606,7 @@ draw_fill_ellipse(DiaRenderer *renderer, Point *to, Point *from,
- else {
- vl.x = 1.0; vl.y = 0.0;
- }
-- if (!finite(vl.x)) {
-+ if (!isfinite(vl.x)) {
- vl.x = 1.0; vl.y = 0.0;
- }
- point_get_perp(&vt,&vl);
-@@ -672,7 +668,7 @@ draw_empty_ellipse(DiaRenderer *renderer, Point *to, Point *from,
- else {
- vl.x = 1.0; vl.y = 0.0;
- }
-- if (!finite(vl.x)) {
-+ if (!isfinite(vl.x)) {
- vl.x = 1.0; vl.y = 0.0;
- }
-
-@@ -718,7 +714,7 @@ calculate_box (Point *poly, const Point *to, const Point *from,
- else {
- vl.x = 1.0; vl.y = 0.0;
- }
-- if (!finite(vl.x)) {
-+ if (!isfinite(vl.x)) {
- vl.x = 1.0; vl.y = 0.0;
- }
- point_get_perp(&vt,&vl);
-@@ -832,7 +828,7 @@ draw_fill_dot(DiaRenderer *renderer, Point *to, Point *from,
- else {
- vl.x = 1.0; vl.y = 0.0;
- }
-- if (!finite(vl.x)) {
-+ if (!isfinite(vl.x)) {
- vl.x = 1.0; vl.y = 0.0;
- }
- point_get_perp(&vt,&vl);
-@@ -908,7 +904,7 @@ draw_integral(DiaRenderer *renderer, Point *to, Point *from,
- else {
- vl.x = 1.0; vl.y = 0.0;
- }
-- if (!finite(vl.x)) {
-+ if (!isfinite(vl.x)) {
- vl.x = 1.0; vl.y = 0.0;
- }
- point_get_perp(&vt,&vl);
-@@ -946,7 +942,7 @@ calculate_slashed (Point *poly, const Point *to, const Point *from,
- else {
- vl.x = 1.0; vl.y = 0.0;
- }
-- if (!finite(vl.x)) {
-+ if (!isfinite(vl.x)) {
- vl.x = 1.0; vl.y = 0.0;
- }
- point_get_perp(&vt,&vl);
-diff --git a/lib/boundingbox.c b/lib/boundingbox.c
-index 6d2749f..6938537 100644
---- a/lib/boundingbox.c
-+++ b/lib/boundingbox.c
-@@ -21,7 +21,7 @@
-
- #include <config.h>
-
--#define _BSD_SOURCE 1
-+#define _GNU_SOURCE 1 /* to get isfinite */
- #include <math.h>
- #include <string.h> /* memcmp() */
-
-@@ -510,7 +510,7 @@ polybezier_bbox(const BezPoint *pts, int numpoints,
- real overshoot;
- Point vovs,pto;
-
-- if (finite(alpha))
-+ if (isfinite(alpha))
- overshoot = extra->middle_trans / sin(alpha/2.0);
- else /* prependicular? */
- overshoot = extra->middle_trans;
-diff --git a/objects/standard/arc.c b/objects/standard/arc.c
-index 28302a6..80674a3 100644
---- a/objects/standard/arc.c
-+++ b/objects/standard/arc.c
-@@ -21,7 +21,7 @@
- #endif
-
- #include <assert.h>
--#define _BSD_SOURCE 1 /* to get finite */
-+#define _GNU_SOURCE 1 /* to get finite */
- #include <math.h>
-
- #include "intl.h"
-@@ -407,7 +407,7 @@ arc_compute_midpoint(Arc *arc, const Point * ep0, const Point * ep1 , Point * mi
- angle -= -atan2(oep0->y - arc->center.y, oep0->x - arc->center.x); /* minus angle of old */
- angle += -atan2(ep1->y - arc->center.y, ep1->x - arc->center.x); /* plus angle of new */
- angle -= -atan2(oep1->y - arc->center.y, oep1->x - arc->center.x); /* minus angle of old */
-- if (!finite(angle)){
-+ if (!isfinite(angle)){
- return 0;
- }
- if (angle < -1 * M_PI){