aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-01-20 08:34:22 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-01-20 08:45:45 +0200
commitf20324ad254a03a3c895cb228465cd53719479cc (patch)
treed757ef472ad6a9ee0237a065d22138831f82abdb
parentc605b8d016348905f7823b0def075fe29ef226c5 (diff)
downloadaports-f20324ad254a03a3c895cb228465cd53719479cc.tar.bz2
aports-f20324ad254a03a3c895cb228465cd53719479cc.tar.xz
testing/ecryptfs-utils: moved from unmaintained
- update to version 111, and update patch - modernize aport - take maintainership
-rw-r--r--testing/ecryptfs-utils/APKBUILD (renamed from unmaintained/ecryptfs-utils/APKBUILD)33
-rw-r--r--testing/ecryptfs-utils/fix-build.patch11
-rw-r--r--unmaintained/ecryptfs-utils/fix-headers.patch28
3 files changed, 23 insertions, 49 deletions
diff --git a/unmaintained/ecryptfs-utils/APKBUILD b/testing/ecryptfs-utils/APKBUILD
index b1c92e82dc..a4bace0b05 100644
--- a/unmaintained/ecryptfs-utils/APKBUILD
+++ b/testing/ecryptfs-utils/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: k0r10n <k0r10n.dev@gmail.com>
-# Maintainer:
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=ecryptfs-utils
-pkgver=104
+pkgver=111
pkgrel=0
pkgdesc="Enterprise-class stacked cryptographic filesystem for Linux"
url="https://launchpad.net/ecryptfs"
@@ -14,22 +14,13 @@ install=""
options="suid"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://launchpad.net/ecryptfs/trunk/${pkgver}/+download/${pkgname}_${pkgver}.orig.tar.gz
- fix-headers.patch
+ fix-build.patch
"
-_builddir="$srcdir"/${pkgname}-${pkgver}
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/${pkgname}-${pkgver}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -43,14 +34,14 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" rootsbindir='/usr/bin' install || return 1
chmod +s "$pkgdir"/usr/bin/mount.ecryptfs_private || return 1
}
-md5sums="6ae93822bcf0d15470516c30a3deee32 ecryptfs-utils_104.orig.tar.gz
-faac9e0f204c62eae4737ffbcf3f1186 fix-headers.patch"
-sha256sums="4a200176542d46439c5297021f2c7fd7343b871c20c6f73f6e6c9fc4e5fd7438 ecryptfs-utils_104.orig.tar.gz
-10256aacf77918bd42bf70171bd714f7ab19311ad86ea083db375a3f77df2baa fix-headers.patch"
-sha512sums="1d093df406c731e6a44bcfc647d5e84a4110fc8d55c8a6aee7e056b0cac8f826b16fbde3dcccd0cf64fcd981a7666b71b1697951ed614ad510c4a6e403f5efd8 ecryptfs-utils_104.orig.tar.gz
-3007e8c845985d07cabbdf2ef7b896f3253fd98f77e0855c2d3087f7224982182b76cb615aeb148e24871268aa061ce5af0310668a516f550a9bd977b88a88f0 fix-headers.patch"
+md5sums="83513228984f671930752c3518cac6fd ecryptfs-utils_111.orig.tar.gz
+d42bb467a5912df0d2e83e9fdd2553dd fix-build.patch"
+sha256sums="112cb3e37e81a1ecd8e39516725dec0ce55c5f3df6284e0f4cc0f118750a987f ecryptfs-utils_111.orig.tar.gz
+7f1038542a3aaba0cf5dd898f2e6e2ffbb9792fecff1a4eb532bb8bc39907fb9 fix-build.patch"
+sha512sums="d8643f3a1f9981fecc6a08b4aa0adb6272e7340db794f6e7507cba7b712247c6beb239f27875eab6e38a69b45bc2476e6bf6b4485eb82d58f65cc469f8613c18 ecryptfs-utils_111.orig.tar.gz
+09ff196e6d3ef54ef57e22e78a4af748c2989928a5c8bc3ece1f8c21c5f301b7e56142c5098111ac853ac88c1b2ee2d0b5c606a210fb53cdf0fde534aa0af92f fix-build.patch"
diff --git a/testing/ecryptfs-utils/fix-build.patch b/testing/ecryptfs-utils/fix-build.patch
new file mode 100644
index 0000000000..6758fdb5b5
--- /dev/null
+++ b/testing/ecryptfs-utils/fix-build.patch
@@ -0,0 +1,11 @@
+--- ecryptfs-utils-111.orig/src/utils/mount.ecryptfs_private.c 2016-01-22 18:04:52.000000000 +0200
++++ ecryptfs-utils-111/src/utils/mount.ecryptfs_private.c 2017-01-20 08:39:31.877975729 +0200
+@@ -235,7 +235,7 @@
+ * deceive other programs with a crafted /proc/self/*. See
+ * https://launchpad.net/bugs/1530566 for more details.
+ */
+- __SWORD_TYPE f_type_whitelist[] = {
++ static const uint32_t f_type_whitelist[] = {
+ 0x61756673 /* AUFS_SUPER_MAGIC */,
+ 0x9123683E /* BTRFS_SUPER_MAGIC */,
+ 0x00C36400 /* CEPH_SUPER_MAGIC */,
diff --git a/unmaintained/ecryptfs-utils/fix-headers.patch b/unmaintained/ecryptfs-utils/fix-headers.patch
deleted file mode 100644
index eb2ca3ec44..0000000000
--- a/unmaintained/ecryptfs-utils/fix-headers.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/src/utils/mount.ecryptfs.c.orig
-+++ b/src/utils/mount.ecryptfs.c
-@@ -24,7 +24,6 @@
- #include <errno.h>
- #include <fcntl.h>
- #include <getopt.h>
--#include <keyutils.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-@@ -34,6 +33,7 @@
- #include <sys/stat.h>
- #include <sys/types.h>
- #include <sys/wait.h>
-+#include <keyutils.h>
- #include "ecryptfs.h"
- #include "decision_graph.h"
- #include "io.h"
---- a/src/utils/mount.ecryptfs_private.c.orig
-+++ b/src/utils/mount.ecryptfs_private.c
-@@ -30,6 +30,7 @@
- #include <sys/param.h>
- #include <sys/stat.h>
- #include <sys/types.h>
-+#include <fcntl.h>
- #include <ctype.h>
- #include <errno.h>
- #include <keyutils.h>