aboutsummaryrefslogtreecommitdiffstats
path: root/community/abiword
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-01-31 13:04:29 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-01-31 13:04:29 -0600
commit28780409ac7168977d453351f8f0b92c33330a78 (patch)
tree30b60800c3e745b98e371bcfdc40a89e6c207b18 /community/abiword
parente4542b09ebc785684dde30af7123d7009e55f6be (diff)
downloadaports-28780409ac7168977d453351f8f0b92c33330a78.tar.bz2
aports-28780409ac7168977d453351f8f0b92c33330a78.tar.xz
community/abiword: build with C++11, disable tests
Tests use valgrind, which reports false errors since it is unaware of musl's internals. Therefore the test always fails.
Diffstat (limited to 'community/abiword')
-rw-r--r--community/abiword/APKBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/community/abiword/APKBUILD b/community/abiword/APKBUILD
index aa3708d44e..77ab3a972d 100644
--- a/community/abiword/APKBUILD
+++ b/community/abiword/APKBUILD
@@ -5,6 +5,7 @@ pkgrel=1
pkgdesc="A fully-featured word processor"
url="http://www.abisource.com"
arch="all"
+options="!check" # Test suite requires valgrind, etc
license="GPL-2.0-or-later"
makedepends="gtk+3.0-dev libgsf-dev enchant-dev fribidi-dev wv-dev
popt-dev libjpeg-turbo-dev librsvg-dev bzip2-dev goffice-dev pcre-dev
@@ -29,14 +30,12 @@ for _i in $_plugins; do
done
source="http://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
- fix-black-drawing-regression.patch
- fix-nullptr-c++98.patch"
+ fix-black-drawing-regression.patch"
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- export CXXFLAGS="$CXXFLAGS -std=gnu++98"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -74,5 +73,4 @@ plugins() {
}
sha512sums="29ce9e80b3b85ab2933e7d39216771d8c4e05db5255eaed0cf8e1d032ffaac2cb1880bf24e754196ad5dae4969a1c2101ce4dc9c1db14604adc2f852b6a17fe3 abiword-3.0.2.tar.gz
-cae9a08047cd97d11acea25a2f0b0ca4e8e4556b462eb476507fa178a7412221839febfeb36bebf491bb94d53525c4584d86230f96c403a7ceb2dec4223be8fe fix-black-drawing-regression.patch
-fbfedad9b58ba44fac53142fae77dce499b9d3f01acb2967e6507b94a8206436240e924ae420c1b92f707a0e08df9874c8de034532032cf6d8df9b28dcd8a3cf fix-nullptr-c++98.patch"
+cae9a08047cd97d11acea25a2f0b0ca4e8e4556b462eb476507fa178a7412221839febfeb36bebf491bb94d53525c4584d86230f96c403a7ceb2dec4223be8fe fix-black-drawing-regression.patch"