aboutsummaryrefslogtreecommitdiffstats
path: root/community/acme-client-plus
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-17 17:05:14 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-17 17:05:36 +0200
commit5794e960c15bf815056da8298461a98ed72f50bb (patch)
tree6cbc16933b41fc7405f19f9b0eed3c8fa5130fab /community/acme-client-plus
parentdcba337eff66349bbaa9fdf834aae1aeaad6bc77 (diff)
downloadaports-5794e960c15bf815056da8298461a98ed72f50bb.tar.bz2
aports-5794e960c15bf815056da8298461a98ed72f50bb.tar.xz
community/acme-client-plus: move from testing
Diffstat (limited to 'community/acme-client-plus')
-rw-r--r--community/acme-client-plus/APKBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/community/acme-client-plus/APKBUILD b/community/acme-client-plus/APKBUILD
new file mode 100644
index 0000000000..6e9f4b0997
--- /dev/null
+++ b/community/acme-client-plus/APKBUILD
@@ -0,0 +1,20 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=acme-client-plus
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="Script for periodic renewal of certificates using BSD's acme-client"
+url="https://github.com/jirutka/acme-client-plus"
+arch="noarch"
+license="ISC"
+depends="acme-client libressl"
+options="!check" # no tests provided
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" prefix=/usr
+}
+
+sha512sums="abdd52cc805b2bda402f4930f403d9152507a635a09bb660fff2d9fcf7ecebf5138abd9e45c41fb0e703848a7cf909fc0b2fa4802108c190b62994bd63523519 acme-client-plus-0.1.1.tar.gz"