aboutsummaryrefslogtreecommitdiffstats
path: root/community/aircrack-ng
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-04-04 18:03:05 +0200
committerTimo Teräs <timo.teras@iki.fi>2018-04-09 11:41:03 +0000
commit3e104fa3c31aeeaa1d1093d4d96b2c10a530c448 (patch)
tree9a2aff56b8b6c57a5854c97b1939bed1e914111a /community/aircrack-ng
parent5e16a9520449e171a91a679267a988b7b7932de8 (diff)
downloadaports-3e104fa3c31aeeaa1d1093d4d96b2c10a530c448.tar.bz2
aports-3e104fa3c31aeeaa1d1093d4d96b2c10a530c448.tar.xz
community/aircrack-ng: update apkbuild, clarify license
Sqlite is by default enabled.
Diffstat (limited to 'community/aircrack-ng')
-rw-r--r--community/aircrack-ng/APKBUILD25
-rw-r--r--community/aircrack-ng/altarches.patch55
2 files changed, 11 insertions, 69 deletions
diff --git a/community/aircrack-ng/APKBUILD b/community/aircrack-ng/APKBUILD
index 01f113d51c..d0f40a4cd1 100644
--- a/community/aircrack-ng/APKBUILD
+++ b/community/aircrack-ng/APKBUILD
@@ -3,14 +3,15 @@
pkgname=aircrack-ng
pkgver=1.2_rc5
_pkgver=${pkgver/_/-}
-pkgrel=1
+pkgrel=2
pkgdesc="Key cracker for the 802.11 WEP and WPA-PSK protocols"
url="http://www.aircrack-ng.org"
arch="all"
-license="GPL-2.0"
+license="GPL-2.0-or-later"
depends="ethtool wireless-tools iw sqlite grep pciutils"
-makedepends="coreutils libressl-dev sqlite-dev libnl-dev linux-headers pcre-dev
- bsd-compat-headers zlib-dev libpcap-dev python3-dev autoconf automake libtool"
+makedepends="autoconf automake libnl3-dev libpcap-dev libressl-dev libtool
+ linux-headers pcre-dev python3-dev sqlite-dev zlib-dev"
+checkdepends="coreutils"
subpackages="$pkgname-doc"
source="http://download.aircrack-ng.org/$pkgname-$_pkgver.tar.gz
make-check-fix.patch"
@@ -22,25 +23,21 @@ prepare() {
autoreconf -fiv
}
-check() {
- cd "$builddir"
- make check
-}
-
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- sqlite=true experimental=true \
- bindir=/usr/bin \
- sbindir=/usr/bin \
- mandir=/usr/share/man/man1/ \
- smandir=/usr/share/man/man8/
+ --with-experimental
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
diff --git a/community/aircrack-ng/altarches.patch b/community/aircrack-ng/altarches.patch
deleted file mode 100644
index 655eeb017a..0000000000
--- a/community/aircrack-ng/altarches.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 252717588f2483a007bbd8bb6ceac3257e8c67e8 Mon Sep 17 00:00:00 2001
-From: Thomas d'Otreppe <tdotreppe@aircrack-ng.org>
-Date: Mon, 15 Feb 2016 05:43:40 +0000
-Subject: [PATCH] Fixing Aircrack-ng compilation on ARM 64 bit.
-
-git-svn-id: http://svn.aircrack-ng.org/trunk@2843 28c6078b-6c39-48e3-add9-af49d547ecab
----
- autocfg | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/autocfg b/autocfg
-index 82fa156..a957ae6 100644
---- a/autocfg
-+++ b/autocfg
-@@ -116,7 +116,7 @@ EOF
- }
-
- case "$CC" in
-- mips-* | arm-*)
-+ mips-* | arm-* | aarch64-* | ppc64* | s390*)
- IS_CROSS=1
- IS_X86=0
- ;;
-@@ -129,7 +129,7 @@ case "$UARCH" in
- x86_64 | amd64 | i*86*)
- IS_X86=1
- ;;
-- *arm*)
-+ *arm* | aarch64)
- IS_ARM=1
- ;;
- *mips*)
-From 913443c9745f72899fdd75e71217dd7b3d76ce34 Mon Sep 17 00:00:00 2001
-From: Thomas d'Otreppe <tdotreppe@aircrack-ng.org>
-Date: Mon, 15 Feb 2016 05:46:41 +0000
-Subject: [PATCH] Fixing Aircrack-ng compilation on ARM 64 bit.
-
-git-svn-id: http://svn.aircrack-ng.org/trunk@2844 28c6078b-6c39-48e3-add9-af49d547ecab
----
- autocfg | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/autocfg b/autocfg
-index a957ae6..6848506 100644
---- a/autocfg
-+++ b/autocfg
-@@ -129,7 +129,7 @@ case "$UARCH" in
- x86_64 | amd64 | i*86*)
- IS_X86=1
- ;;
-- *arm* | aarch64)
-+ *arm* | *aarch64* | ppc64* | s390*)
- IS_ARM=1
- ;;
- *mips*)