aboutsummaryrefslogtreecommitdiffstats
path: root/community/apache-ant
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-30 17:09:42 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-03-30 17:10:07 +0200
commita387983bfeaf05ef9c1df5aa4d051f7ed9d7f4ac (patch)
tree481382d2736581f0821adc65f204781491c03485 /community/apache-ant
parent1efc5728f357cd5ce8439e53d2976e8f0cebc8cb (diff)
downloadaports-a387983bfeaf05ef9c1df5aa4d051f7ed9d7f4ac.tar.bz2
aports-a387983bfeaf05ef9c1df5aa4d051f7ed9d7f4ac.tar.xz
community/apache-ant: remove "return 1" from abuild
Diffstat (limited to 'community/apache-ant')
-rw-r--r--community/apache-ant/APKBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/community/apache-ant/APKBUILD b/community/apache-ant/APKBUILD
index 8eefd9254f..857b4cbb47 100644
--- a/community/apache-ant/APKBUILD
+++ b/community/apache-ant/APKBUILD
@@ -4,13 +4,12 @@
pkgname=apache-ant
pkgver=1.10.3
pkgrel=0
-pkgdesc="A java-based build tool."
+pkgdesc="A java-based build tool"
url="http://ant.apache.org/"
arch="noarch"
options="!check" # Needs itself for testing.
license="Apache-2.0"
depends="openjdk8-jre-base"
-makedepends=""
source="http://archive.apache.org/dist/ant/binaries/$pkgname-$pkgver-bin.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"
@@ -32,25 +31,25 @@ package() {
install -dm755 "$destdir"/bin
rm bin/*.bat bin/*.cmd
- install -m755 bin/* "$destdir"/bin || return 1
+ install -m755 bin/* "$destdir"/bin
install -dm755 "$pkgdir"/usr/bin
- ln -sf $_anthome/bin/ant "$pkgdir"/usr/bin/ant || return 1
+ ln -sf $_anthome/bin/ant "$pkgdir"/usr/bin/ant
- cp -r etc "$destdir"/ || return 1
+ cp -r etc "$destdir"/
install -dm755 "$destdir"/lib
- install -m644 lib/*.jar "$destdir"/lib || return 1
+ install -m644 lib/*.jar "$destdir"/lib
# symlink to junit so it's on the javac build path for ant
# matches behavior on ubuntu 9 and makes sense for compatibility
# http://bugs.archlinux.org/task/15229
- ln -sf ../../junit.jar "$destdir"/lib/junit.jar || return 1
+ ln -sf ../../junit.jar "$destdir"/lib/junit.jar
# The license says the NOTICE file should be redistributed for
# derivative works, so lets supply it.
local file; for file in LICENSE NOTICE; do
- install -m644 -D $file "$pkgdir"/usr/share/licenses/$pkgname/$file || return 1
+ install -m644 -D $file "$pkgdir"/usr/share/licenses/$pkgname/$file
done
install -m644 -D $pkgname.sh "$pkgdir"/etc/profile.d/$pkgname.sh