aboutsummaryrefslogtreecommitdiffstats
path: root/community/appstream-glib
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-17 08:34:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-17 08:44:05 +0000
commit2f58e71ea18b9afd8f0ff836f7dce89d46a75e83 (patch)
tree54e607a7af99986a05b0f78673c758482564f0fb /community/appstream-glib
parent9ce6e8abe90b9ec6b89b56072cd45c308a14e8fa (diff)
downloadaports-2f58e71ea18b9afd8f0ff836f7dce89d46a75e83.tar.bz2
aports-2f58e71ea18b9afd8f0ff836f7dce89d46a75e83.tar.xz
main/appstream-glib: move to community
Diffstat (limited to 'community/appstream-glib')
-rw-r--r--community/appstream-glib/APKBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/community/appstream-glib/APKBUILD b/community/appstream-glib/APKBUILD
new file mode 100644
index 0000000000..63cf2f0f2a
--- /dev/null
+++ b/community/appstream-glib/APKBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=appstream-glib
+pkgver=0.6.3
+pkgrel=0
+pkgdesc="Library for AppStream metadata"
+url="https://people.freedesktop.org/~hughsient/appstream-glib/"
+arch="all"
+license="LGPL-2.0-or-later"
+depends=""
+depends_dev="glib-dev gdk-pixbuf-dev"
+makedepends="$depends_dev fontconfig-dev freetype-dev pango-dev sqlite-dev
+ gobject-introspection-dev gtk-doc yaml-dev libarchive-dev libsoup-dev
+ gtk+3.0-dev json-glib-dev libgcab-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-builder"
+source="https://people.freedesktop.org/~hughsient/appstream-glib/releases/appstream-glib-$pkgver.tar.xz"
+
+_builddir="$srcdir"/appstream-glib-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ DATADIRNAME=share ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-rpm \
+ --enable-shared \
+ --disable-static \
+ --enable-gobject-introspection \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+builder() {
+ pkgdesc="Library and command line tools for building AppStream metadata"
+ mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/lib \
+ "$subpkgdir"/usr/share/bash-completion/completions || return 1
+ mv "$pkgdir"/usr/bin/appstream-builder "$subpkgdir"/usr/bin/ || return 1
+ mv "$pkgdir"/usr/share/bash-completion/completions/appstream-builder \
+ "$subpkgdir"/usr/share/bash-completion/completions/ || return 1
+ mv "$pkgdir"/usr/lib/asb-plugins-5 \
+ "$pkgdir"/usr/lib/libappstream-builder.so.* \
+ "$subpkgdir"/usr/lib/ || return 1
+}
+
+md5sums="2654b73dd55dcc2a1b52f3a19ed7cdd0 appstream-glib-0.6.3.tar.xz"
+sha256sums="3ec355c950b86cd792b6e396a5a4a72487999e300fcacf7466a663974ec4ad24 appstream-glib-0.6.3.tar.xz"
+sha512sums="aae4885e32bc6f0247f6e8f415471531a8c28976e1ba4bd977200d72e24a04dfc2370395e3e0ea6e052386a963540cb91f025cd4f1ab837404762f1be2a76ff0 appstream-glib-0.6.3.tar.xz"