aboutsummaryrefslogtreecommitdiffstats
path: root/community/apt-dater-host
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2018-01-10 08:33:45 +0100
committerWilliam Pitcock <nenolod@dereferenced.org>2018-01-10 07:57:10 +0000
commit7de23116a961c9011c245f644ff6e08398298e09 (patch)
tree62267e3b45c4114499bda980b40460b9f0331a9f /community/apt-dater-host
parente975641dc85c14821d222e376edcc3017da269aa (diff)
downloadaports-7de23116a961c9011c245f644ff6e08398298e09.tar.bz2
aports-7de23116a961c9011c245f644ff6e08398298e09.tar.xz
community/apt-dater-host: move from testing
Diffstat (limited to 'community/apt-dater-host')
-rw-r--r--community/apt-dater-host/APKBUILD34
-rw-r--r--community/apt-dater-host/apt-dater-host-fix-bashisms.patch12
2 files changed, 46 insertions, 0 deletions
diff --git a/community/apt-dater-host/APKBUILD b/community/apt-dater-host/APKBUILD
new file mode 100644
index 0000000000..5997903c1c
--- /dev/null
+++ b/community/apt-dater-host/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Maintainer: Henrik Riomar <henrik.riomar@gmail.com>
+pkgname=apt-dater-host
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="Host helper application for apt-dater"
+url="https://github.com/DE-IBH/apt-dater-host"
+arch="noarch"
+license="GPL-2.0-or-later"
+checkdepends="bats checkbashisms"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/DE-IBH/$pkgname/archive/v$pkgver.tar.gz
+ apt-dater-host-fix-bashisms.patch
+ "
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+check() {
+ cd "$builddir"/apk
+ make check
+
+ checkbashisms ./apt-dater-host
+}
+
+package() {
+ cd "$builddir"/apk
+ make install DESTDIR="$pkgdir"
+
+ cd "$builddir"/man
+ install -d -m0755 "$pkgdir"/usr/share/man/man1
+ install -m0644 "$pkgname".1 "$pkgdir"/usr/share/man/man1
+}
+sha512sums="52d48ade6758cb1150be2f21ed4c9831b4254ccc749ae865321abea077737a49ff7aeefb4e643aa289d953d2847dcf83e94837fe510fa8f8bfe19cfda0fd9dbc apt-dater-host-1.0.1.tar.gz
+6f695e1b1785f88217b5a32c509b5cb3c7a3f70069b042ad9770a4c1e86c4477abab2763579130f65e0c880976eb9f292bed3b42dda0d25e801696db479e55e8 apt-dater-host-fix-bashisms.patch"
diff --git a/community/apt-dater-host/apt-dater-host-fix-bashisms.patch b/community/apt-dater-host/apt-dater-host-fix-bashisms.patch
new file mode 100644
index 0000000000..8af008f38d
--- /dev/null
+++ b/community/apt-dater-host/apt-dater-host-fix-bashisms.patch
@@ -0,0 +1,12 @@
+diff -urN a/apk/apt-dater-host b/apk/apt-dater-host
+--- a/apk/apt-dater-host 2017-09-19 17:29:23.873543499 +0200
++++ b/apk/apt-dater-host 2017-09-19 17:29:53.406954004 +0200
+@@ -168,7 +168,7 @@
+ shift
+
+ proxy="/etc/profile.d/proxy.sh"
+- [ -r $proxy ] && source $proxy
++ [ -r $proxy ] && . $proxy
+
+ cmd="$ROOT_CMD $*"
+ $cmd