aboutsummaryrefslogtreecommitdiffstats
path: root/community/asio/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-21 14:14:57 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-21 14:44:37 +0000
commitce70b431e56abd102144a28b14bdd47d26457dc6 (patch)
tree4a804cd69c32de29c33bf1074b883b8081d33292 /community/asio/APKBUILD
parentbf8f6d8dd9ac29b0146b6cc7eb235d936ae7ad15 (diff)
downloadaports-ce70b431e56abd102144a28b14bdd47d26457dc6.tar.bz2
aports-ce70b431e56abd102144a28b14bdd47d26457dc6.tar.xz
community/asio: moved from testing
Diffstat (limited to 'community/asio/APKBUILD')
-rw-r--r--community/asio/APKBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/community/asio/APKBUILD b/community/asio/APKBUILD
new file mode 100644
index 0000000000..bf5e8f22c6
--- /dev/null
+++ b/community/asio/APKBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=asio
+pkgver=1.10.6
+_ver=${pkgver//./-}
+pkgrel=1
+pkgdesc="A cross-platform C++ library for network programming"
+url="https://think-async.com"
+arch="all"
+license="Boost"
+depends=""
+depends_dev="boost-dev libressl-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/project/asio/asio/${pkgver}%20%28Stable%29/asio-$pkgver.tar.bz2
+ fix-strerror_r.patch
+ libressl.patch
+ "
+
+_builddir="$srcdir"/asio-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="85d014a356a6e004cd30ccd4c9b6a5c2 asio-1.10.6.tar.bz2
+dfc0d5d1c14ca0a247d835c944e400a6 fix-strerror_r.patch
+7b3d05cf45e59abc04a61549a401fb82 libressl.patch"
+sha256sums="e0d71c40a7b1f6c1334008fb279e7361b32a063e020efd21e40d9d8ff037195e asio-1.10.6.tar.bz2
+0b3eb6d74c9dd11e08368da0f9e09446e2383b5fc840e630581fef3672db95ac fix-strerror_r.patch
+6b78adbf094b956e2b3451cfd19a73b1f2c12a9a78a491d64819dd0276239991 libressl.patch"
+sha512sums="7146e75a378de57daab88e7ba509ae01367ffa0d7c4c90481e221977a6b9f4fd80e9caac5c6b4c27bc7652e44cd210e2c6cabf5681d7c62747df14bbc25e8c23 asio-1.10.6.tar.bz2
+a023e305a9efa6b93489374dfe9881c447d748a8d48ff803e0ac7ff1be618460b57de024e79da8c08dab4bcd214cbf2c3991d963eef678ca8dbd48b3c8933a70 fix-strerror_r.patch
+6caeb4748f1a68783e2da3f548f3a4f91e413d96ba3a508b8279f04a1fd1f73f8d5d53f1b2bb1accf2a15bd3056144fce64668bf06091550055d125aef2169b7 libressl.patch"