aboutsummaryrefslogtreecommitdiffstats
path: root/community/asio
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-09 21:16:19 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-09 21:16:19 +0000
commit5614f0eeeb81989b59db9f81bdd0a3f173281319 (patch)
tree6afb5cf11d7486130eb0fb9b3ec9baa156ea9eb4 /community/asio
parentc2a648d1170f1b7fab853b00c35b0d786777f64a (diff)
downloadaports-5614f0eeeb81989b59db9f81bdd0a3f173281319.tar.bz2
aports-5614f0eeeb81989b59db9f81bdd0a3f173281319.tar.xz
community/asio: add check
Diffstat (limited to 'community/asio')
-rw-r--r--community/asio/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/asio/APKBUILD b/community/asio/APKBUILD
index 09d65c474c..97f6a3ffcc 100644
--- a/community/asio/APKBUILD
+++ b/community/asio/APKBUILD
@@ -2,7 +2,7 @@
pkgname=asio
pkgver=1.12.0
_ver=${pkgver//./-}
-pkgrel=0
+pkgrel=1
pkgdesc="A cross-platform C++ library for network programming"
url="https://think-async.com"
arch="all"
@@ -31,6 +31,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install