aboutsummaryrefslogtreecommitdiffstats
path: root/community/astyle
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-16 01:55:48 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-16 01:57:23 +0000
commit2d13526e29e5f2e386621fec6cde9115b5e85413 (patch)
tree3b7763c65a627c4fde23676b691d420832b2ef0b /community/astyle
parentfd86c6fa83e21ee448fce7e70f6fbfbc7a27fdc7 (diff)
downloadaports-2d13526e29e5f2e386621fec6cde9115b5e85413.tar.bz2
aports-2d13526e29e5f2e386621fec6cde9115b5e85413.tar.xz
community/astyle: fix ppc64le build
On systems without glibc, you might lack definition of PATH_MAX. This patch adds the limits.h header to solve this issue. PS: I will send this patch upstream latter
Diffstat (limited to 'community/astyle')
-rw-r--r--community/astyle/APKBUILD17
-rw-r--r--community/astyle/fix-ppc64le-build.patch10
2 files changed, 20 insertions, 7 deletions
diff --git a/community/astyle/APKBUILD b/community/astyle/APKBUILD
index 436963c09c..f963cfdc75 100644
--- a/community/astyle/APKBUILD
+++ b/community/astyle/APKBUILD
@@ -1,28 +1,31 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=astyle
pkgver=3.1
-pkgrel=0
+pkgrel=1
pkgdesc="An automatic code formatter"
url="http://sourceforge.net/projects/astyle"
arch="all"
license="LGPL"
-source="http://downloads.sourceforge.net/sourceforge/astyle/${pkgname}_${pkgver}_linux.tar.gz"
-builddir="$srcdir/$pkgname/build/gcc"
+source="http://downloads.sourceforge.net/sourceforge/astyle/${pkgname}_${pkgver}_linux.tar.gz
+fix-ppc64le-build.patch"
+
+builddir="$srcdir/$pkgname"
build() {
- cd "$builddir"
+ cd "$builddir/build/gcc"
make release
}
check() {
- cd "$builddir"
+ cd "$builddir/build/gcc"
# upstream do not provide tests
./bin/astyle --version
}
package() {
- cd "$builddir"
+ cd "$builddir/build/gcc"
install -Dm0755 bin/astyle "$pkgdir/usr/bin/astyle"
}
-sha512sums="2e8f13d291abda66bbba30174c364c81a81a490e0a21376f7da7cf471644c22caa37b9eefb100d093bf26d1a8bfa9d2f14b4c2a9b75b3cb84428b4514e277ff2 astyle_3.1_linux.tar.gz"
+sha512sums="2e8f13d291abda66bbba30174c364c81a81a490e0a21376f7da7cf471644c22caa37b9eefb100d093bf26d1a8bfa9d2f14b4c2a9b75b3cb84428b4514e277ff2 astyle_3.1_linux.tar.gz
+ef934980659777d398ee53f20b68f94e06aa8e2c9036dc257adbfbc99b5b45914914011aa34d0015f7d60fa43daed39527ff335fed95c721a85aeb4b2a7675c5 fix-ppc64le-build.patch"
diff --git a/community/astyle/fix-ppc64le-build.patch b/community/astyle/fix-ppc64le-build.patch
new file mode 100644
index 0000000000..048dd82c1f
--- /dev/null
+++ b/community/astyle/fix-ppc64le-build.patch
@@ -0,0 +1,10 @@
+--- a/src/astyle_main.cpp
++++ b/src/astyle_main.cpp
+@@ -41,6 +41,7 @@
+ #include <cstdlib>
+ #include <fstream>
+ #include <sstream>
++#include <limits.h>
+
+ // includes for recursive getFileNames() function
+ #ifdef _WIN32