aboutsummaryrefslogtreecommitdiffstats
path: root/community/astyle
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-11-26 22:40:26 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-28 12:12:05 +0000
commit8eb6fbc0a77ff670bba75c670b5546ff8e099184 (patch)
treeafa4ebdc58893f6c092586722fb7fd33d37bcf6f /community/astyle
parent0fc5de62a3d8ee00733785818bbb9e10c5e17dac (diff)
downloadaports-8eb6fbc0a77ff670bba75c670b5546ff8e099184.tar.bz2
aports-8eb6fbc0a77ff670bba75c670b5546ff8e099184.tar.xz
community/astyle: moved from testing
Diffstat (limited to 'community/astyle')
-rw-r--r--community/astyle/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/astyle/APKBUILD b/community/astyle/APKBUILD
new file mode 100644
index 0000000000..6796ff37a0
--- /dev/null
+++ b/community/astyle/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=astyle
+pkgver=3.0.1
+pkgrel=0
+pkgdesc="An automatic code formatter"
+url="http://sourceforge.net/projects/astyle"
+arch="all"
+license="LGPL"
+source="http://downloads.sourceforge.net/sourceforge/astyle/${pkgname}_${pkgver}_linux.tar.gz"
+builddir="$srcdir/$pkgname/build/gcc"
+
+build() {
+ cd "$builddir"
+ make release
+}
+
+check() {
+ cd "$builddir"
+ # upstream do not provide tests
+ ./bin/astyle --version
+}
+
+package() {
+ cd "$builddir"
+ install -Dm0755 bin/astyle "$pkgdir/usr/bin/astyle"
+}
+
+sha512sums="3e8d617c0ec89682bfb076081bb63ae9d44e897de0c85d5109b28adbbfe0620d5dacf59a4bd96ac30a5a4fcb3be136758e9c6fe2c69258b37956c212890a7158 astyle_3.0.1_linux.tar.gz"