aboutsummaryrefslogtreecommitdiffstats
path: root/community/audacity
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-13 13:48:44 -0300
committerShiz <hi@shiz.me>2017-05-14 03:33:43 +0200
commit0f7769ab6247acf35102d621296ed2527ed3cc5f (patch)
treeb07eee2dc37eefbb05994b97b67f32088257db20 /community/audacity
parentb561ce3e3810bd9235907d7a4626d09789b6f249 (diff)
downloadaports-0f7769ab6247acf35102d621296ed2527ed3cc5f.tar.bz2
aports-0f7769ab6247acf35102d621296ed2527ed3cc5f.tar.xz
community/audacity: modernize aport
Diffstat (limited to 'community/audacity')
-rw-r--r--community/audacity/APKBUILD33
1 files changed, 7 insertions, 26 deletions
diff --git a/community/audacity/APKBUILD b/community/audacity/APKBUILD
index ab88c891d5..301417b5dd 100644
--- a/community/audacity/APKBUILD
+++ b/community/audacity/APKBUILD
@@ -7,8 +7,6 @@ pkgdesc="Multitrack audio editor"
url="http://audacity.sourceforge.net"
arch="all"
license="GPL2"
-depends=""
-depends_dev=""
makedepends="$depends_dev
alsa-lib-dev
bash
@@ -28,28 +26,18 @@ makedepends="$depends_dev
wxgtk2.8-dev
"
-install=""
subpackages="$pkgname-doc $pkgname-lang"
source="https://github.com/audacity/audacity/archive/Audacity-$pkgver.tar.gz
musl-workaround.patch
filedialog.patch
"
-_builddir="$srcdir"/audacity-Audacity-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/audacity-Audacity-$pkgver
build() {
local _arch
- cd "$_builddir"
+ cd "$builddir"
case "$CTARGET" in
x86|x86_64) _arch="--enable-sse";;
@@ -79,26 +67,19 @@ build() {
--without-libsamplerate \
--without-ffmpeg \
--enable-nyquist \
- $_arch \
- || return 1
+ $_arch
for i in ffmpeg libsoxr libvamp portaudio-v19; do
- rm -r lib-src/$i || return 1
+ rm -r lib-src/$i
done
- make || return 1
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-md5sums="7cd627dc61da8b3698d234c96aee284d Audacity-2.1.1.tar.gz
-f4d0e4b195c2f604cea8e8d696ffcc17 musl-workaround.patch
-555ef97e2caf27ada49b13eb79b5f058 filedialog.patch"
-sha256sums="15c5ff7ac1c0b19b08f4bdcb0f4988743da2f9ed3fab41d6f07600e67cb9ddb6 Audacity-2.1.1.tar.gz
-888e2a0c0055f11300ecaa550aff5ab1991dbce3b2dab0d05596c3b304b2c675 musl-workaround.patch
-3cb764eec45ece3631c66546576746735a91b78e37d1ec608837bf568bee4647 filedialog.patch"
sha512sums="00b0a037ffefb670e7148414224c60330c4fb915a892cb635537caeba82815d0113c5bb07f7b2805ed9b42a1a75106ef6fdc2f1602fd5042c48cc5e111a34ffb Audacity-2.1.1.tar.gz
b5488a7f5398c07fe986e090b8d61353ecba594ed23fda6a4444e59718f7d1e8bd5c716047ce139350983d5609b5810362a78a2fd5d85e9b1730d196c57c685b musl-workaround.patch
7f10b5f53ada9faa7ad887400a5729a41228f8970ee4cc045291e9b203a9f7f068b09f709e23f7f2a15724acf82ed0e4bccfd163b2232b430d2c89b86ccc2751 filedialog.patch"