aboutsummaryrefslogtreecommitdiffstats
path: root/community/audacity
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-25 13:48:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-25 13:48:31 +0000
commitd25f6e1109beb363084b6622d646241177984b0d (patch)
tree61eed63b71cd52a0970d7bd53e89f41825dad306 /community/audacity
parent8ffb33173619d5a262ba40ac88f8525cae0cede4 (diff)
downloadaports-d25f6e1109beb363084b6622d646241177984b0d.tar.bz2
aports-d25f6e1109beb363084b6622d646241177984b0d.tar.xz
community/audacity: move from main
Diffstat (limited to 'community/audacity')
-rw-r--r--community/audacity/APKBUILD104
-rw-r--r--community/audacity/filedialog.patch13
-rw-r--r--community/audacity/musl-workaround.patch16
3 files changed, 133 insertions, 0 deletions
diff --git a/community/audacity/APKBUILD b/community/audacity/APKBUILD
new file mode 100644
index 0000000000..039cc56ba4
--- /dev/null
+++ b/community/audacity/APKBUILD
@@ -0,0 +1,104 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=audacity
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="Multitrack audio editor"
+url="http://audacity.sourceforge.net"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev
+ alsa-lib-dev
+ bash
+ expat-dev
+ flac-dev
+ jack-dev
+ lame-dev
+ libid3tag-dev
+ libmad-dev
+ libogg-dev
+ libsndfile-dev
+ libvorbis-dev
+ portaudio-dev
+ soundtouch-dev
+ soxr-dev
+ taglib-dev
+ wxgtk2.8-dev
+ "
+
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://github.com/audacity/audacity/archive/Audacity-$pkgver.tar.gz
+ musl-workaround.patch
+ filedialog.patch
+ "
+
+_builddir="$srcdir"/audacity-Audacity-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ local _arch
+
+ cd "$_builddir"
+
+ case "$CTARGET" in
+ x86|x86_64) _arch="--enable-sse";;
+ *) _arch="--disable-sse";;
+ esac
+
+ LIBNYQUIST_USE_LOCAL=yes \
+ CFLAGS="$CFLAGS -fPIC" \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --with-expat=system \
+ --with-lib-preference=system \
+ --with-libsndfile=system \
+ --with-libflac=system \
+ --with-coundtouch=system \
+ --with-soxr=system \
+ --with-id3tag=system \
+ --with-libvorbis=system \
+ --with-portaudio=system \
+ --with-libmad=system \
+ --with-widgetextra=local \
+ --without-libresample \
+ --without-libsamplerate \
+ --without-ffmpeg \
+ --enable-nyquist \
+ $_arch \
+ || return 1
+
+ for i in ffmpeg libsoxr libvamp portaudio-v19; do
+ rm -r lib-src/$i || return 1
+ done
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="7cd627dc61da8b3698d234c96aee284d Audacity-2.1.1.tar.gz
+f4d0e4b195c2f604cea8e8d696ffcc17 musl-workaround.patch
+555ef97e2caf27ada49b13eb79b5f058 filedialog.patch"
+sha256sums="15c5ff7ac1c0b19b08f4bdcb0f4988743da2f9ed3fab41d6f07600e67cb9ddb6 Audacity-2.1.1.tar.gz
+888e2a0c0055f11300ecaa550aff5ab1991dbce3b2dab0d05596c3b304b2c675 musl-workaround.patch
+3cb764eec45ece3631c66546576746735a91b78e37d1ec608837bf568bee4647 filedialog.patch"
+sha512sums="00b0a037ffefb670e7148414224c60330c4fb915a892cb635537caeba82815d0113c5bb07f7b2805ed9b42a1a75106ef6fdc2f1602fd5042c48cc5e111a34ffb Audacity-2.1.1.tar.gz
+b5488a7f5398c07fe986e090b8d61353ecba594ed23fda6a4444e59718f7d1e8bd5c716047ce139350983d5609b5810362a78a2fd5d85e9b1730d196c57c685b musl-workaround.patch
+7f10b5f53ada9faa7ad887400a5729a41228f8970ee4cc045291e9b203a9f7f068b09f709e23f7f2a15724acf82ed0e4bccfd163b2232b430d2c89b86ccc2751 filedialog.patch"
diff --git a/community/audacity/filedialog.patch b/community/audacity/filedialog.patch
new file mode 100644
index 0000000000..0232c5619d
--- /dev/null
+++ b/community/audacity/filedialog.patch
@@ -0,0 +1,13 @@
+diff --git a/lib-src/FileDialog/generic/FileDialogPrivate.cpp b/lib-src/FileDialog/generic/FileDialogPrivate.cpp
+index 315a4cb..baa2e60 100644
+--- a/lib-src/FileDialog/generic/FileDialogPrivate.cpp
++++ b/lib-src/FileDialog/generic/FileDialogPrivate.cpp
+@@ -392,7 +392,7 @@ void FileData::MakeItem( wxListItem &item )
+ if (IsLink())
+ {
+ wxColour dg = wxTheColourDatabase->Find( wxT("MEDIUM GREY") );
+- if ( dg.Ok() )
++ if ( dg.IsOk() )
+ item.SetTextColour(dg);
+ }
+ item.m_data = (long)this;
diff --git a/community/audacity/musl-workaround.patch b/community/audacity/musl-workaround.patch
new file mode 100644
index 0000000000..ababf90366
--- /dev/null
+++ b/community/audacity/musl-workaround.patch
@@ -0,0 +1,16 @@
+The use of RTLD_DEEPBIND is just a workaround and not a real fix.
+And we cannot use it...
+
+--- ./src/effects/VST/VSTEffect.cpp.orig
++++ ./src/effects/VST/VSTEffect.cpp
+@@ -2609,6 +2609,10 @@
+ // symbols.
+ //
+ // Once we define a proper external API, the flags can be removed.
++// GNU extension
++#ifndef RTLD_DEEPBIND
++#define RTLD_DEEPBIND 0
++#endif
+ void *lib = dlopen((const char *)wxString(realPath).ToUTF8(), RTLD_NOW | RTLD_LOCAL | RTLD_DEEPBIND);
+ if (!lib)
+ {