aboutsummaryrefslogtreecommitdiffstats
path: root/community/avr-libc
diff options
context:
space:
mode:
authorStefan Wagner <stw@bit-strickerei.de>2016-08-18 20:01:37 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-18 21:21:06 +0200
commit2f2883cc10692bcb0db5997907b081268fad8d79 (patch)
treed81d38b511465f265bd65324bb46fdfeee4749e6 /community/avr-libc
parentbe6dec1f57e2315d6b3e04d81be7d2220edbdf7f (diff)
downloadaports-2f2883cc10692bcb0db5997907b081268fad8d79.tar.bz2
aports-2f2883cc10692bcb0db5997907b081268fad8d79.tar.xz
testing/[various]: move to community
Diffstat (limited to 'community/avr-libc')
-rw-r--r--community/avr-libc/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/avr-libc/APKBUILD b/community/avr-libc/APKBUILD
new file mode 100644
index 0000000000..40a4617e96
--- /dev/null
+++ b/community/avr-libc/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Stefan Wagner <stw@bit-strickerei.de>
+# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
+pkgname=avr-libc
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="The C runtime library for the AVR family of microcontrollers"
+url="http://savannah.nongnu.org/projects/avr-libc/"
+depends="gcc-avr"
+makedepends="autoconf automake bash"
+arch="all"
+license="BSD"
+subpackages="$pkgname-doc"
+source="http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.bz2"
+
+builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$builddir"
+ ./bootstrap || return 1
+ CC=avr-gcc ./configure \
+ --build="$(./config.guess)" \
+ --host=avr \
+ --prefix=/usr || return 1
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" || return 1
+ if [ -d "$pkgdir"/usr/lib64 ]; then
+ mv "$pkgdir"/usr/lib64/* "$pkgdir"/usr/lib/
+ rmdir "$pkgdir"/usr/lib64
+ fi
+}
+
+md5sums="2360981cd5d94e1d7a70dfc6983bdf15 avr-libc-2.0.0.tar.bz2"
+sha256sums="b2dd7fd2eefd8d8646ef6a325f6f0665537e2f604ed02828ced748d49dc85b97 avr-libc-2.0.0.tar.bz2"
+sha512sums="fc8d062043d633350dbe05978935dcb8028257a4f1013f246af9658aef0671def19ac11577d1ee9302df68df1b8cf030b22441d96852e185db212263aacabea6 avr-libc-2.0.0.tar.bz2"