aboutsummaryrefslogtreecommitdiffstats
path: root/community/bam
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-06-16 06:52:46 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-06-16 08:32:51 +0000
commit144e91436b1ce41382dd63d7ddb2f5d6d195e5c1 (patch)
tree14c56847a348ccdc279669d11c8725f62dd643dc /community/bam
parente316d123f313509137f4eb26ae3ba6b2266a9e93 (diff)
downloadaports-144e91436b1ce41382dd63d7ddb2f5d6d195e5c1.tar.bz2
aports-144e91436b1ce41382dd63d7ddb2f5d6d195e5c1.tar.xz
community/bam: upgrade to 0.5.1
Diffstat (limited to 'community/bam')
-rw-r--r--community/bam/APKBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/community/bam/APKBUILD b/community/bam/APKBUILD
index e48d74f2c0..25ad232460 100644
--- a/community/bam/APKBUILD
+++ b/community/bam/APKBUILD
@@ -2,29 +2,26 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
pkgname=bam
-#teeworlds is sole user of bam, and requires 0.4.x currently
-pkgver=0.4.0
+pkgver=0.5.1
pkgrel=0
-pkgdesc='Fast and flexible build system using Lua'
+pkgdesc="Fast and flexible build system using Lua"
arch=all
-url=http://github.com/matricks/bam
+url="http://github.com/matricks/bam"
+makedepends="lua5.3-dev luajit-dev"
license='ZLIB'
-
-#source="$pkgname-$pkgver.tar.gz::https://github.com/matricks/bam/archive/v$pkgver.tar.gz"
-source="https://downloads.teeworlds.com/bam-$pkgver.tar.gz"
+option="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/matricks/bam/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$builddir"
sh make_unix.sh || return 1
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
- install -Dm755 bam "$pkgdir"/usr/bin/bam || return 1
- install -Dm755 license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE \
- || return 1
+ cd "$builddir"
+ install -Dm755 bam "$pkgdir"/usr/bin/bam
+ install -Dm755 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="2f8e8336b8884110e8a355b12c9fa58a bam-0.4.0.tar.gz"
-sha256sums="5e4e4920b4d265da582f66774e9b1ec8ddfbe75ddc028fba86c12f686ea18db3 bam-0.4.0.tar.gz"
-sha512sums="c599cdf3618d317a5d304febd2e59d1116fc5819cdaf49969fdc25f88ed8f3e25831861c0c7fea05059d8af7085b654a7732bd89086bc166661b932d168ee2ca bam-0.4.0.tar.gz"
+sha512sums="e6f1b3daad6073c58b0e3cbf836bb0a6b66f0c36532d6e6eca9949239ab8b584cc88f892cce6f74974e370a8a688f33a95dde86dd65cc1790e49e5f8aeab0fef bam-0.5.1.tar.gz"