aboutsummaryrefslogtreecommitdiffstats
path: root/community/bareos-webui
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2017-08-27 15:11:28 +0300
committerFrancesco Colista <fcolista@alpinelinux.org>2017-08-29 11:21:00 +0000
commit6417f50c04e83cb4e8926585314c7d0fc3090a65 (patch)
tree8502dca0e49b473d01cedbd2d6afe18574e9e2fb /community/bareos-webui
parent5c03f9f0f78ce6af15ac61aef2fceb12787b9d67 (diff)
downloadaports-6417f50c04e83cb4e8926585314c7d0fc3090a65.tar.bz2
aports-6417f50c04e83cb4e8926585314c7d0fc3090a65.tar.xz
community/bareos-webui: upgrade to 16.2.6, switch to php7
Diffstat (limited to 'community/bareos-webui')
-rw-r--r--community/bareos-webui/APKBUILD51
-rw-r--r--community/bareos-webui/nginx-conf.patch31
2 files changed, 64 insertions, 18 deletions
diff --git a/community/bareos-webui/APKBUILD b/community/bareos-webui/APKBUILD
index 8e51f115fd..13b62e4deb 100644
--- a/community/bareos-webui/APKBUILD
+++ b/community/bareos-webui/APKBUILD
@@ -1,41 +1,56 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+_php=php7
pkgname=bareos-webui
-pkgver=15.2.4
+pkgver=16.2.6
pkgrel=0
pkgdesc="Bareos Web User Interface"
url="http://www.bareos.org/en/bareos-webui.html"
arch="noarch"
+options="!check"
license=" AGPL-3.0"
-depends="zendframework php5"
-makedepends=""
-install=""
-subpackages="$pkgname-apache2"
-source="$pkgname-$pkgver.tar.gz::https://github.com/bareos/$pkgname/archive/Release/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-Release-$pkgver"
+depends="$_php-bz2 $_php-ctype $_php-curl $_php-dom $_php-fileinfo $_php-gettext $_php-gd
+ $_php-iconv $_php-intl $_php-json $_php-mbstring $_php-openssl $_php-session
+ $_php-simplexml $_php-xml $_php-xmlreader $_php-xmlwriter $_php-zip
+ "
+makedepends="apache2-dev findutils gettext"
+subpackages="$pkgname-apache2 $pkgname-nginx"
+source="$pkgname-$pkgver.tar.gz::https://github.com/bareos/$pkgname/archive/Release/$pkgver.tar.gz
+ nginx-conf.patch"
+builddir="$srcdir"/$pkgname-Release-$pkgver
+
+prepare() {
+ default_prepare
+ sed -i -e "s/mod_php5/mod_$_php/" "$builddir"/install/apache/$pkgname.conf
+ sed -i -e "s/-dir//" "$builddir"/install/directors.ini
+}
build() {
cd "$builddir"
- ./configure \
- --prefix=/usr \
- --with-httpd-conf=/etc/apache2/conf.d
- make || return 1
+ ./configure --prefix=/usr
+ make
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
+ mv "$pkgdir"/etc/bareos/bareos-dir.d/console/admin.conf.example \
+ "$pkgdir"/etc/bareos/bareos-dir.d/console/admin.conf
}
apache2() {
- pkgdesc="Apache configuration files for $pkgname"
- depends="apache2 php5-apache2"
-
+ pkgdesc="$pkgdesc (apache2 configuration files)"
+ depends="$pkgname $_php-apache2"
mkdir -p "$subpkgdir"/etc/
- mv "$pkgdir"/etc/apache2 "$subpkgdir"/etc/apache2
+ mv "$pkgdir"/etc/apache2 "$subpkgdir"/etc/
}
+nginx() {
+ pkgdesc="$pkgdesc (nginx configuration files)"
+ depends="$pkgname nginx"
+ install -Dm644 "$builddir"/install/nginx/$pkgname.conf "$subpkgdir"/etc/nginx/conf.d/$pkgname.conf
+}
-md5sums="5fe5b692133d414e04da3728c5ccc6f6 bareos-webui-15.2.4.tar.gz"
-sha256sums="4a6a40cd398bacd01cbf0e8a0de183ba7054c3c66c36c1cc72cc9e5ee42ee016 bareos-webui-15.2.4.tar.gz"
-sha512sums="93e56c4bca84f26d49d19ca88f0a07964782af5bcab37289bf83c42ae525ec738e3fdfe8cafc2c236a5e1f24908854927b47242ab7b3320653f60cdd0d7111b1 bareos-webui-15.2.4.tar.gz"
+sha512sums="21ba3a4360c091e2c1aff8ebaa37f32e174a8f2133fc878b27ab9bd5bdbf2b804049f644a0702e525cad0820fb301c2fbd77203082115db8f07fbc698a004c96 bareos-webui-16.2.6.tar.gz
+f015fed04d1ab2d1410d3abe37329d2b48ecc54cd5fa0a0dd560c83ce0b9f04383219e6fa77d6a42752aeec8c26f9a27d53048edf0672435ef1e0cadaf2bae17 nginx-conf.patch"
diff --git a/community/bareos-webui/nginx-conf.patch b/community/bareos-webui/nginx-conf.patch
new file mode 100644
index 0000000000..d0df2d6515
--- /dev/null
+++ b/community/bareos-webui/nginx-conf.patch
@@ -0,0 +1,31 @@
+--- a/install/nginx/bareos-webui.conf
++++ b/install/nginx/bareos-webui.conf
+@@ -2,7 +2,7 @@
+
+ listen 9100;
+ server_name bareos;
+- root /var/www/bareos-webui/public;
++ root /usr/share/bareos-webui/public;
+
+ location / {
+ index index.php;
+@@ -11,17 +11,9 @@
+
+ location ~ .php$ {
+
+- include snippets/fastcgi-php.conf;
++ include fastcgi.conf;
+
+- # With php5-cgi alone pass the PHP
+- # scripts to FastCGI server
+- # listening on 127.0.0.1:9000
+-
+- # fastcgi_pass 127.0.0.1:9000;
+-
+- # With php5-fpm:
+-
+- fastcgi_pass unix:/var/run/php5-fpm.sock;
++ fastcgi_pass 127.0.0.1:9000;
+
+ # Set APPLICATION_ENV to either 'production' or 'development'
+