aboutsummaryrefslogtreecommitdiffstats
path: root/community/bats
diff options
context:
space:
mode:
authorDario Ernst <dario@kanojo.de>2018-02-01 16:13:05 +0100
committerHenrik Riomar <henrik.riomar@gmail.com>2018-06-28 20:42:45 +0200
commitcfd49c0ec7fdfbf734f35919f0a277a85efdbdb5 (patch)
treea43de40040cdbde67244131cf1e6d869f4e4eb80 /community/bats
parent04213a552282023ed2e893047cf1643dd9cce03f (diff)
downloadaports-cfd49c0ec7fdfbf734f35919f0a277a85efdbdb5.tar.bz2
aports-cfd49c0ec7fdfbf734f35919f0a277a85efdbdb5.tar.xz
community/bats: Update to first successor release
sstephenson/bats has been abandoned for quite some time. The designated successor-fork seems to be bats-core/bats-core. bats-core has now recently released a stable version, which we package now. The custom patch also has been removed, since libexec/bats-format-tap-stream:5 already seems to check for tput availability. The doc package now depends on man, since it only contains man-pages.
Diffstat (limited to 'community/bats')
-rw-r--r--community/bats/0001-test-bats-Add-fake-tput-to-fix-Alpine-tests.patch35
-rw-r--r--community/bats/APKBUILD28
2 files changed, 8 insertions, 55 deletions
diff --git a/community/bats/0001-test-bats-Add-fake-tput-to-fix-Alpine-tests.patch b/community/bats/0001-test-bats-Add-fake-tput-to-fix-Alpine-tests.patch
deleted file mode 100644
index 1b29f81949..0000000000
--- a/community/bats/0001-test-bats-Add-fake-tput-to-fix-Alpine-tests.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 1ed87ecb7f0b8f2be4c04aed242f2114975ab8e1 Mon Sep 17 00:00:00 2001
-From: Mike Bland <mbland@acm.org>
-Date: Mon, 2 Oct 2017 22:02:00 -0400
-Subject: [PATCH] test/bats: Add fake tput to fix Alpine tests
-
-The test cases that use the `-p` or `--pretty` flag would fail if `tput`
-wasn't available (installed as part of the `ncurses` package). On
-Alpine, `ncurses` isn't installed by default. This change ensures the
-tests validate the expected behavior regardless of whether `tput` is
-available.
----
- test/test_helper.bash | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/test/test_helper.bash b/test/test_helper.bash
-index 302f743..af89003 100644
---- a/test/test_helper.bash
-+++ b/test/test_helper.bash
-@@ -11,6 +11,13 @@ filter_control_sequences() {
- "$@" | sed $'s,\x1b\\[[0-9;]*[a-zA-Z],,g'
- }
-
-+if ! command -v tput >/dev/null; then
-+ tput() {
-+ printf '1000\n'
-+ }
-+ export -f tput
-+fi
-+
- teardown() {
- [ -d "$TMP" ] && rm -f "$TMP"/*
- }
---
-2.15.0
-
diff --git a/community/bats/APKBUILD b/community/bats/APKBUILD
index 0e37c36101..1ffc4780a0 100644
--- a/community/bats/APKBUILD
+++ b/community/bats/APKBUILD
@@ -1,16 +1,16 @@
# Maintainer: Jose-Luis Rivas <ghostbar@riseup.net>
pkgname=bats
-pkgver=0.4.0
-pkgrel=2
+pkgver=1.0.2
+pkgrel=0
pkgdesc="Bash Automated Testing System"
-url="https://github.com/sstephenson/bats"
+url="https://github.com/bats-core/bats-core"
arch="noarch"
license="MIT"
depends="bash"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/sstephenson/$pkgname/archive/v$pkgver.tar.gz
- 0001-test-bats-Add-fake-tput-to-fix-Alpine-tests.patch"
-builddir="$srcdir/$pkgname-$pkgver"
+depends_doc="man"
+source="$pkgname-$pkgver.zip::https://github.com/bats-core/bats-core/archive/v$pkgver.zip"
+builddir="$srcdir/bats-core-$pkgver"
check() {
cd "$builddir"
@@ -19,18 +19,6 @@ check() {
package() {
cd "$builddir"
-
- mkdir -p "$pkgdir"/usr/lib/bats "$pkgdir"/usr/bin
-
- # Note: We don't use /usr/libexec in Alpine.
- cp -r libexec/* "$pkgdir"/usr/lib/bats
- ln -s ../lib/bats/bats "$pkgdir"/usr/bin/bats
-
- local i; for i in 1 7; do
- install -m 644 -D man/bats.$i \
- "$pkgdir"/usr/share/man/man$i/bats.$i
- done
+ ./install.sh "$pkgdir"/usr
}
-
-sha512sums="83c6c0e3ceec149708a8db5d33e95cc84852d8189498c22131c00f4288a6c870f9d522bae9230157f442338dc101e1468451d78dfa274afb83a6f0dd614c8bdb bats-0.4.0.tar.gz
-f6e6453e0cd783dc6835cd1f1e256bc8fcfad2ba1611bd4901cf586cb227788516ef74cadcad05889b15a23251a2c23f3f07e4676c1d229cb80bec8e8bf49394 0001-test-bats-Add-fake-tput-to-fix-Alpine-tests.patch"
+sha512sums="3c45db6640c61a47b1f1a3d1a4a4fe64ad11558f71b3c2f70498a93287a7484279c8a750d2ed4c97069b812345588d843b2b571afceeaee9781e2a9e448172d4 bats-1.0.2.zip"