aboutsummaryrefslogtreecommitdiffstats
path: root/community/blind
diff options
context:
space:
mode:
authorJean-Louis Fuchs <ganwell@fangorn.ch>2017-10-03 20:52:17 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-10-20 07:09:26 +0000
commit9b0882821333917b5ac26466fd02d844be11029c (patch)
tree269e3b1293b6f27136c01d9de670f406ee48a2ab /community/blind
parent610a62d3321f856f62d5271ae558d5cf1e3ae986 (diff)
downloadaports-9b0882821333917b5ac26466fd02d844be11029c.tar.bz2
aports-9b0882821333917b5ac26466fd02d844be11029c.tar.xz
community/blind: move from testing
Diffstat (limited to 'community/blind')
-rw-r--r--community/blind/APKBUILD47
-rw-r--r--community/blind/fix-readall.patch23
-rw-r--r--community/blind/test.ff.bz2bin0 -> 2403 bytes
3 files changed, 70 insertions, 0 deletions
diff --git a/community/blind/APKBUILD b/community/blind/APKBUILD
new file mode 100644
index 0000000000..683105e3ac
--- /dev/null
+++ b/community/blind/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor:Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+pkgname=blind
+pkgver=1.1
+pkgrel=1
+pkgdesc="blind is a collection of command line video editing utilities"
+url="http://tools.suckless.org/blind/"
+arch="all"
+license="ISC"
+checkdepends="ffmpeg"
+subpackages="$pkgname-doc"
+source="http://dl.suckless.org/tools/blind-$pkgver.tar.gz
+ fix-readall.patch
+ test.ff.bz2
+"
+builddir="$srcdir/blind-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ # Check if blind is operational
+ bunzip2 < "$srcdir/test.ff.bz2" | ./blind-from-image -f > test.bl
+ ./blind-repeat 15 test.bl | ./blind-flop | ./blind-flip \
+ | ./blind-dissolve | ./blind-to-video 50 -c:v libx264 -preset fast -crf 0 \
+ -pix_fmt yuv444p out.mp4
+ rm test.bl out.mp4
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+ cp blind-rotate-* "$pkgdir/usr/bin/"
+}
+
+md5sums="46370b2da4997fb9dda6653cf81f5cf0 blind-1.1.tar.gz
+17ca341f9ec9fa29680e07af1552122d fix-readall.patch
+433d1680f8820eb0b21f143948498fbb test.ff.bz2"
+sha256sums="24f903ccb5e118d75f38d3ae0d85fed909749f978bff47ff6973ee1bfddfcc5a blind-1.1.tar.gz
+2a5835b376838062e6858ce5ea0953eefdbe560bfa37e2bed3cb39bdbb3da1b6 fix-readall.patch
+5fdb176ad0653d3d6b3ce332deeaeff01a69ea0fed4cd9967b41a73a47cec19a test.ff.bz2"
+sha512sums="620a5edc69bf736f642948e4f6ac6dda8cdbea4bdad143b09f931e62aaa57983e23ff60961d1485dcbce1ac461be12b393fe03f056ef46ca5ad2012cb03cf637 blind-1.1.tar.gz
+cc5ef6e5d84202a4194b4858177d7385674208338de5ce68918838d162ad57bc89f738484bda3bdb2e121fb75029fe74bbf460e92d0ba6b3a678883f151002f9 fix-readall.patch
+0834032e1e416824883658478b8cc2821df9b41cf4f169f471df0476c35dfe4a6bcc9c103e5522e54d7f820f77710e3215c691fa39311f6be3310cb1745e2b73 test.ff.bz2"
diff --git a/community/blind/fix-readall.patch b/community/blind/fix-readall.patch
new file mode 100644
index 0000000000..1e5ebfdacb
--- /dev/null
+++ b/community/blind/fix-readall.patch
@@ -0,0 +1,23 @@
+---
+ src/util.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/util.c b/src/util.c
+index 6c1bd0a..8967392 100644
+--- a/src/util.c
++++ b/src/util.c
+@@ -136,9 +136,9 @@ readall(int fd, void *buf, size_t n)
+ return -1;
+ if (r == 0)
+ break;
+- r += (size_t)r;
++ ptr += (size_t)r;
+ }
+- return r;
++ return ptr;
+ }
+
+ int
+--
+2.11.1
+
diff --git a/community/blind/test.ff.bz2 b/community/blind/test.ff.bz2
new file mode 100644
index 0000000000..8469a22452
--- /dev/null
+++ b/community/blind/test.ff.bz2
Binary files differ