aboutsummaryrefslogtreecommitdiffstats
path: root/community/bogofilter
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-08-18 12:58:33 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-18 21:11:39 +0000
commitfad19051951129081c94d9ca641af6bbb1389e20 (patch)
tree4f6fac56923653086b9db2df0052a834b70b6966 /community/bogofilter
parent5df6fbc76284929c44d2db7db6d12f675a91958c (diff)
downloadaports-fad19051951129081c94d9ca641af6bbb1389e20.tar.bz2
aports-fad19051951129081c94d9ca641af6bbb1389e20.tar.xz
testing/[various]: move to community
Moves the following packages to community after successful build and testing. bogofilter corebird fbpanel hermes libdbi-drivers luufs netsurf opencpn py-sensehat rng-tools volumeicon
Diffstat (limited to 'community/bogofilter')
-rw-r--r--community/bogofilter/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/bogofilter/APKBUILD b/community/bogofilter/APKBUILD
new file mode 100644
index 0000000000..508c165196
--- /dev/null
+++ b/community/bogofilter/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=bogofilter
+pkgver=1.2.4
+pkgrel=0
+pkgdesc="A Bayesian mail filter that classifies mail by statistical analysis of the message's header and content."
+url="http://bogofilter.sourceforge.net/"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="sqlite-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/bogofilter/bogofilter-stable/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.bz2"
+
+builddir=${srcdir}/${pkgname}-${pkgver}
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --with-included-gsl \
+ --with-database=sqlite3 || return 1
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR=${pkgdir} install
+}
+
+md5sums="d0a5eebb3274b23ceabe766a6443a1c5 bogofilter-1.2.4.tar.bz2"
+sha256sums="e10287a58d135feaea26880ce7d4b9fa2841fb114a2154bf7da8da98aab0a6b4 bogofilter-1.2.4.tar.bz2"
+sha512sums="e8c0b6bcc14f12fbbb2752e697a6d9065e17abfca3f70045ce9fe668d01c1cfad4adaa35c81546ecdd3639b0c28f3f4776bb5ed4699f21e9e2a5b19ca33479db bogofilter-1.2.4.tar.bz2"