aboutsummaryrefslogtreecommitdiffstats
path: root/community/cabal
diff options
context:
space:
mode:
authorMitch Tishmack <mitch.tishmack@gmail.com>2017-05-28 15:09:51 -0500
committerShiz <hi@shiz.me>2017-06-02 10:41:50 +0200
commitf9bf9190e451d69e6c6ea07b1c9c57ffdb1b5148 (patch)
tree24f480d3d055ff9dc7b3c0dd01e12ddbc25714cc /community/cabal
parent244a27917cc67db95bbc5d160fec908857fa1cb2 (diff)
downloadaports-f9bf9190e451d69e6c6ea07b1c9c57ffdb1b5148.tar.bz2
aports-f9bf9190e451d69e6c6ea07b1c9c57ffdb1b5148.tar.xz
community/cabal: build without profiling enabled
Saves on build time for things we won't ever use building profiled library support for libraries and the executable, also saves a skosh on size. Ref difference betwen r0->r1: $ apk info cabal cabal-1.24.0.2-r1 description: The Haskell Cabal cabal-1.24.0.2-r1 webpage: http://haskell.org cabal-1.24.0.2-r1 installed size: 18051072 cabal-1.24.0.2-r0 description: The Haskell Cabal cabal-1.24.0.2-r0 webpage: http://haskell.org cabal-1.24.0.2-r0 installed size: 18993152
Diffstat (limited to 'community/cabal')
-rw-r--r--community/cabal/APKBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/community/cabal/APKBUILD b/community/cabal/APKBUILD
index bac65b9e4b..76ff24b7c4 100644
--- a/community/cabal/APKBUILD
+++ b/community/cabal/APKBUILD
@@ -8,7 +8,7 @@ url="http://haskell.org"
arch="armhf x86_64"
license="BSD3"
depends="gmp zlib"
-makedepends="ghc ghc-dev gmp-dev libffi-dev zlib-dev binutils-gold chrpath"
+makedepends="ghc gmp-dev libffi-dev zlib-dev binutils-gold chrpath"
subpackages="$pkgname-doc"
source="
cabal-0001-force-ld.gold.patch
@@ -69,12 +69,7 @@ prepare() {
build() {
cd "$builddir"
- (
- export HOME="$builddir"
- export NO_DOCUMENTATION=1
- export EXTRA_BUILD_OPTS="--ghc-option=-fllvm"
- ./bootstrap.sh
- )
+ env HOME="$builddir" NO_DOCUMENTATION=1 EXTRA_CONFIGURE_OPTS="" ./bootstrap.sh
}
package() {