aboutsummaryrefslogtreecommitdiffstats
path: root/community/cargo/replace-openssl-crate.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-13 02:02:54 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-13 02:04:20 +0100
commitf2e48a64207dba29ed888969fc70f5caa8d135c5 (patch)
tree92bbdc03460de51f4cc0064b241fdfd640394a31 /community/cargo/replace-openssl-crate.patch
parent28372d03e30d7298921432d0d4413606573e37ce (diff)
downloadaports-f2e48a64207dba29ed888969fc70f5caa8d135c5.tar.bz2
aports-f2e48a64207dba29ed888969fc70f5caa8d135c5.tar.xz
community/cargo: fix compatibility with libressl 2.6.3
See https://github.com/sfackler/rust-openssl/pull/759
Diffstat (limited to 'community/cargo/replace-openssl-crate.patch')
-rw-r--r--community/cargo/replace-openssl-crate.patch150
1 files changed, 150 insertions, 0 deletions
diff --git a/community/cargo/replace-openssl-crate.patch b/community/cargo/replace-openssl-crate.patch
new file mode 100644
index 0000000000..daf92f00b9
--- /dev/null
+++ b/community/cargo/replace-openssl-crate.patch
@@ -0,0 +1,150 @@
+Use local openssl and openssl-sys crates patched for LibreSSL 2.6.3.
+
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -75,3 +75,7 @@
+ name = "cargo"
+ test = false
+ doc = false
++
++[replace]
++"openssl:0.9.20" = { path = "openssl/openssl" }
++"openssl-sys:0.9.20" = { path = "openssl/openssl-sys" }
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -30,7 +30,7 @@
+ "log 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)",
+ "miow 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "num_cpus 1.6.2 (registry+https://github.com/rust-lang/crates.io-index)",
+- "openssl 0.9.15 (registry+https://github.com/rust-lang/crates.io-index)",
++ "openssl 0.9.20 (registry+https://github.com/rust-lang/crates.io-index)",
+ "psapi-sys 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "same-file 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ "scoped-tls 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -138,6 +138,11 @@
+ ]
+
+ [[package]]
++name = "cc"
++version = "1.0.3"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++
++[[package]]
+ name = "cfg-if"
+ version = "0.1.2"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+@@ -200,7 +205,7 @@
+ "curl-sys 0.3.14 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.28 (registry+https://github.com/rust-lang/crates.io-index)",
+ "openssl-probe 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
+- "openssl-sys 0.9.15 (registry+https://github.com/rust-lang/crates.io-index)",
++ "openssl-sys 0.9.20 (registry+https://github.com/rust-lang/crates.io-index)",
+ "socket2 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "winapi 0.2.8 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+@@ -213,7 +218,7 @@
+ "gcc 0.3.51 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.28 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libz-sys 1.0.16 (registry+https://github.com/rust-lang/crates.io-index)",
+- "openssl-sys 0.9.15 (registry+https://github.com/rust-lang/crates.io-index)",
++ "openssl-sys 0.9.20 (registry+https://github.com/rust-lang/crates.io-index)",
+ "pkg-config 0.3.9 (registry+https://github.com/rust-lang/crates.io-index)",
+ "vcpkg 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ "winapi 0.2.8 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -318,7 +323,7 @@
+ "libc 0.2.28 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libgit2-sys 0.6.12 (registry+https://github.com/rust-lang/crates.io-index)",
+ "openssl-probe 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
+- "openssl-sys 0.9.15 (registry+https://github.com/rust-lang/crates.io-index)",
++ "openssl-sys 0.9.20 (registry+https://github.com/rust-lang/crates.io-index)",
+ "url 1.5.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+
+@@ -445,7 +450,7 @@
+ "libc 0.2.28 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libssh2-sys 0.2.6 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libz-sys 1.0.16 (registry+https://github.com/rust-lang/crates.io-index)",
+- "openssl-sys 0.9.15 (registry+https://github.com/rust-lang/crates.io-index)",
++ "openssl-sys 0.9.20 (registry+https://github.com/rust-lang/crates.io-index)",
+ "pkg-config 0.3.9 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+
+@@ -457,7 +462,7 @@
+ "cmake 0.1.24 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.28 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libz-sys 1.0.16 (registry+https://github.com/rust-lang/crates.io-index)",
+- "openssl-sys 0.9.15 (registry+https://github.com/rust-lang/crates.io-index)",
++ "openssl-sys 0.9.20 (registry+https://github.com/rust-lang/crates.io-index)",
+ "pkg-config 0.3.9 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+
+@@ -623,32 +628,43 @@
+
+ [[package]]
+ name = "openssl"
+-version = "0.9.15"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
++version = "0.9.20"
+ dependencies = [
+ "bitflags 0.9.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "foreign-types 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "lazy_static 0.2.8 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.28 (registry+https://github.com/rust-lang/crates.io-index)",
+- "openssl-sys 0.9.15 (registry+https://github.com/rust-lang/crates.io-index)",
++ "openssl-sys 0.9.20",
+ ]
+
+ [[package]]
++name = "openssl"
++version = "0.9.20"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++replace = "openssl 0.9.20"
++
++[[package]]
+ name = "openssl-probe"
+ version = "0.1.1"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+
+ [[package]]
+ name = "openssl-sys"
+-version = "0.9.15"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
++version = "0.9.20"
+ dependencies = [
+- "gcc 0.3.51 (registry+https://github.com/rust-lang/crates.io-index)",
++ "cc 1.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.28 (registry+https://github.com/rust-lang/crates.io-index)",
+ "pkg-config 0.3.9 (registry+https://github.com/rust-lang/crates.io-index)",
++ "vcpkg 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+
+ [[package]]
++name = "openssl-sys"
++version = "0.9.20"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++replace = "openssl-sys 0.9.20"
++
++[[package]]
+ name = "percent-encoding"
+ version = "1.0.0"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+@@ -1013,6 +1029,7 @@
+ "checksum bitflags 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)" = "aad18937a628ec6abcd26d1489012cc0e18c21798210f491af69ded9b881106d"
+ "checksum bitflags 0.9.1 (registry+https://github.com/rust-lang/crates.io-index)" = "4efd02e230a02e18f92fc2735f44597385ed02ad8f831e7c1c1156ee5e1ab3a5"
+ "checksum bufstream 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)" = "f2f382711e76b9de6c744cc00d0497baba02fb00a787f088c879f01d09468e32"
++"checksum cc 1.0.3 (registry+https://github.com/rust-lang/crates.io-index)" = "a9b13a57efd6b30ecd6598ebdb302cca617930b5470647570468a65d12ef9719"
+ "checksum cfg-if 0.1.2 (registry+https://github.com/rust-lang/crates.io-index)" = "d4c819a1287eb618df47cc647173c5c4c66ba19d888a6e50d605672aed3140de"
+ "checksum cmake 0.1.24 (registry+https://github.com/rust-lang/crates.io-index)" = "b8ebbb35d3dc9cd09497168f33de1acb79b265d350ab0ac34133b98f8509af1f"
+ "checksum conv 0.3.3 (registry+https://github.com/rust-lang/crates.io-index)" = "78ff10625fd0ac447827aa30ea8b861fead473bb60aeb73af6c1c58caf0d1299"
+@@ -1067,9 +1084,9 @@
+ "checksum num-rational 0.1.39 (registry+https://github.com/rust-lang/crates.io-index)" = "288629c76fac4b33556f4b7ab57ba21ae202da65ba8b77466e6d598e31990790"
+ "checksum num-traits 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)" = "99843c856d68d8b4313b03a17e33c4bb42ae8f6610ea81b28abe076ac721b9b0"
+ "checksum num_cpus 1.6.2 (registry+https://github.com/rust-lang/crates.io-index)" = "aec53c34f2d0247c5ca5d32cca1478762f301740468ee9ee6dcb7a0dd7a0c584"
+-"checksum openssl 0.9.15 (registry+https://github.com/rust-lang/crates.io-index)" = "f776f1d8af832fd2c637ee182c801e8f7ea8895718a2be9914cca001f6e2c40a"
++"checksum openssl 0.9.20 (registry+https://github.com/rust-lang/crates.io-index)" = "8bf434ff6117485dc16478d77a4f5c84eccc9c3645c4da8323b287ad6a15a638"
+ "checksum openssl-probe 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)" = "d98df0270d404ccd3c050a41d579c52d1db15375168bb3471e04ec0f5f378daf"
+-"checksum openssl-sys 0.9.15 (registry+https://github.com/rust-lang/crates.io-index)" = "ad95f8160d1c150c4f44d4c4959732e048ac046c37f597fe362f8bf57561ffb4"
++"checksum openssl-sys 0.9.20 (registry+https://github.com/rust-lang/crates.io-index)" = "0ad395f1cee51b64a8d07cc8063498dc7554db62d5f3ca87a67f4eed2791d0c8"
+ "checksum percent-encoding 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)" = "de154f638187706bde41d9b4738748933d64e6b37bdbffc0b47a97d16a6ae356"
+ "checksum pkg-config 0.3.9 (registry+https://github.com/rust-lang/crates.io-index)" = "3a8b4c6b8165cd1a1cd4b9b120978131389f64bdaf456435caa41e630edba903"
+ "checksum psapi-sys 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)" = "abcd5d1a07d360e29727f757a9decb3ce8bc6e0efa8969cfaad669a8317a2478"