aboutsummaryrefslogtreecommitdiffstats
path: root/community/certbot
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-05-16 09:08:02 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-05-16 09:08:07 +0000
commit2e1f183226ec8b85a8dbcaa2a8136844faa2346c (patch)
tree3f4a278f629ac604a20e78d32c4752207c3f7aa6 /community/certbot
parent29aefa0456449c70e33ab8d6af5b9b478284f626 (diff)
downloadaports-2e1f183226ec8b85a8dbcaa2a8136844faa2346c.tar.bz2
aports-2e1f183226ec8b85a8dbcaa2a8136844faa2346c.tar.xz
community/certbot: renamed from letencrypt, added wrapper for letsencrypt binary, upgrade to 0.6.0
Diffstat (limited to 'community/certbot')
-rw-r--r--community/certbot/APKBUILD51
-rw-r--r--community/certbot/letsencrypt-wrapper6
2 files changed, 57 insertions, 0 deletions
diff --git a/community/certbot/APKBUILD b/community/certbot/APKBUILD
new file mode 100644
index 0000000000..63698a38aa
--- /dev/null
+++ b/community/certbot/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=certbot
+pkgver=0.6.0
+pkgrel=0
+pkgdesc="An ACME client that can update Apache/Nginx configurations"
+url="https://github.com/certbot/certbot"
+arch="noarch"
+license="Apache"
+depends="py-setuptools py-mock py-acme py-configargparse py-configobj
+ py-cryptography py-parsedatetime py-psutil py-dialog py-openssl
+ py-rfc3339 py-tz py-requests py-six py-zope-component py-zope-interface
+ py-zope-event py-cffi py-enum34 py-ipaddress py-idna"
+# define acme deps here and add them to makedepends
+# so they get pulled in when bootstrapping.
+_depends_acme="py-setuptools py-cryptography py-ndg_httpsclient py-asn1 py-openssl
+ py-tz py-rfc3339 py-requests py-six py-werkzeug"
+provides="letsencrypt"
+depends_dev=""
+makedepends="$depends_dev $_depends_acme"
+install=""
+subpackages="py-acme:acme"
+source="certbot-$pkgver.tar.gz::https://github.com/certbot/certbot/archive/v$pkgver.tar.gz
+ letsencrypt-wrapper"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ install -m755 "$srcdir"/letsencrypt-wrapper "$pkgdir"/usr/bin/letsencrypt
+}
+
+acme() {
+ pkgdesc="ACME protocol implementation for Python"
+ depends="$_depends_acme"
+ cd "$_builddir"/acme
+ python setup.py build || return 1
+ python setup.py install --prefix=/usr --root="$subpkgdir" || return 1
+}
+
+md5sums="350c3cecbb066b96739a50cba04f5d4c certbot-0.6.0.tar.gz
+98c8ab7fede335bd00b0f0d85cd447e1 letsencrypt-wrapper"
+sha256sums="58eaa6be4ae90af07d682296e42dbac924b5602c51002445059596313e182a09 certbot-0.6.0.tar.gz
+4f3a6b71ce80f96f65204fe9c1509a299b5d856a1cc60b99c0dd869269badeff letsencrypt-wrapper"
+sha512sums="966fdbff13ac9651ebb5fafae86a58a45538d57a43eb6d157358bbecef4286634bb61dd13b94e0ca5b006980a35cc5fe55b4a12efdeadc2530653d844516c926 certbot-0.6.0.tar.gz
+db22121e32f9654b9b27883fc405b727ba85426d4122b901bf494d3ccf12bf1d2093b68979c005551762cc1ea80c5e5a442098504e3aa0e1b9286dca4819c24c letsencrypt-wrapper"
diff --git a/community/certbot/letsencrypt-wrapper b/community/certbot/letsencrypt-wrapper
new file mode 100644
index 0000000000..ef70a969b6
--- /dev/null
+++ b/community/certbot/letsencrypt-wrapper
@@ -0,0 +1,6 @@
+#!/bin/sh
+echo >&2
+echo "Warning: letsencrypt has been renamed in certbot." >&2
+echo "From the next version, this wrapper will be removed." >&2
+echo >&2
+/usr/bin/certbot $@