aboutsummaryrefslogtreecommitdiffstats
path: root/community/chicken
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-03-13 12:19:26 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2017-03-13 12:22:21 +0100
commit9328aadbabc5e6f3549654943219ff8b44dea13d (patch)
tree7e627066a5205ef7f9e21b1ee917491453812ec3 /community/chicken
parentc5f5d0b3bbc8740edf4e41fd7b2d98c75cc2e1f9 (diff)
downloadaports-9328aadbabc5e6f3549654943219ff8b44dea13d.tar.bz2
aports-9328aadbabc5e6f3549654943219ff8b44dea13d.tar.xz
community/chicken: add check function
Diffstat (limited to 'community/chicken')
-rw-r--r--community/chicken/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/chicken/APKBUILD b/community/chicken/APKBUILD
index ba687d1ada..e84f89b614 100644
--- a/community/chicken/APKBUILD
+++ b/community/chicken/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=chicken
pkgver=4.12.0
-pkgrel=0
+pkgrel=1
pkgdesc="R5RS and R7RS compatible scheme compiler and interpreter"
url="http://call-cc.org/"
arch="all"
@@ -27,6 +27,11 @@ build() {
-C "$builddir" || return 1
}
+check() {
+ make -j1 PLATFORM=linux \
+ -C "$builddir" check || return 1
+}
+
package() {
# chicken does not support parallel installs.
make -j1 PLATFORM=linux PREFIX=/usr DESTDIR="$pkgdir" \