aboutsummaryrefslogtreecommitdiffstats
path: root/community/claws-mail
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-14 13:59:51 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-09 14:46:46 +0000
commit1665362a3a33b064f06ac6c422dcbc9330e40427 (patch)
tree8d43fdae550dcdab8ec4f0918373c97cb688494f /community/claws-mail
parent855dc6535686ce41300b004792cd69a9b822c74d (diff)
downloadaports-1665362a3a33b064f06ac6c422dcbc9330e40427.tar.bz2
aports-1665362a3a33b064f06ac6c422dcbc9330e40427.tar.xz
community/claws-mail: upgrade to 3.15.0 and modernize
Diffstat (limited to 'community/claws-mail')
-rw-r--r--community/claws-mail/APKBUILD33
1 files changed, 10 insertions, 23 deletions
diff --git a/community/claws-mail/APKBUILD b/community/claws-mail/APKBUILD
index d61379b619..108a99481a 100644
--- a/community/claws-mail/APKBUILD
+++ b/community/claws-mail/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Ɓukasz Jendrysik
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=claws-mail
-pkgver=3.14.1
-pkgrel=2
+pkgver=3.15.0
+pkgrel=0
pkgdesc="A GTK+ based e-mail client."
url="http://www.claws-mail.org"
arch="all"
@@ -36,21 +36,11 @@ makedepends="gtk+-dev libressl-dev startup-notification-dev enchant-dev
pinentry-gtk spamassassin
"
depends="aspell-en"
-install=
source="http://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1 ;;
- esac
- done
-}
-
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
DATADIRNAME=share ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -67,20 +57,19 @@ build() {
--enable-pdf_viewer-plugin \
--disable-jpilot \
--disable-bsfilter-plugin \
- --disable-newmail-plugin \
- || return 1
+ --disable-newmail-plugin
# force disabling of backtrace. the core dump was more useful
sed -i -e '/HAVE_BACKTRACE/d' config.h
- make || return 1
+ make
cd tools
make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find tools -maxdepth 1 -type f -and -perm 111 -or -name '*.conf' | while read i; do
install -D -m755 ${i} "$pkgdir"/usr/lib/claws-mail/tools/${i}
done
@@ -94,7 +83,7 @@ _plugin() {
mkdir -p "$subpkgdir"/usr/lib/claws-mail/plugins
for _i; do
mv "$pkgdir"/usr/lib/claws-mail/plugins/${_i}* \
- "$subpkgdir"/usr/lib/claws-mail/plugins/ || return 1
+ "$subpkgdir"/usr/lib/claws-mail/plugins/
done
}
@@ -179,6 +168,4 @@ _vcalendar () {
_plugin "Handling of vCalendar messages in Claws Mail" "" vcalendar
}
-md5sums="67ff80ab414fda46e2d7977431c823f5 claws-mail-3.14.1.tar.gz"
-sha256sums="b195f87a3b6eca6ee60afb74b3253c18713c34315f133fc46171add80ccabf23 claws-mail-3.14.1.tar.gz"
-sha512sums="aba89ada808e16b5b663b5ba9007cdcc91551a5bb287ee7af1c0e77fdbf946d45d81f6cd294b694906e97293d2392ead78b0e496554c72401ce52c6cd85c2e00 claws-mail-3.14.1.tar.gz"
+sha512sums="90850f90b353c993498e1710668105e3d359cb98adb04ab9cf6597d1b8593d34630cf41ed2cbe6c38fd030d1a14fc49aab2a4d9c2852999778b896271c0ddd7a claws-mail-3.15.0.tar.gz"