aboutsummaryrefslogtreecommitdiffstats
path: root/community/cmus
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-06-27 10:17:05 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-07-04 11:42:28 +0200
commit2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd (patch)
tree97c60fb3221dfe78cd7ccfda5db6125c81d5f676 /community/cmus
parent00e8ff605f1c4f6386596f35f2a5287ff9b8bc55 (diff)
downloadaports-2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd.tar.bz2
aports-2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd.tar.xz
testing/[various]: move packages to community
Moves the packages listed below from the testing to the community repository after successfully testing of said packages. asciinema at calcurse cmus compton cpio dvd+rw-tools fortune fvwm geary h2o heirloom-mailx leafpad nedit nmh rover tor torsocks urlview vdesk w3m wbar xcalc xclock xeyes xkill
Diffstat (limited to 'community/cmus')
-rw-r--r--community/cmus/APKBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/community/cmus/APKBUILD b/community/cmus/APKBUILD
new file mode 100644
index 0000000000..2b9bfabcd3
--- /dev/null
+++ b/community/cmus/APKBUILD
@@ -0,0 +1,60 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+pkgname=cmus
+pkgver=2.7.1
+pkgrel=2
+pkgdesc="A very feature-rich ncurses-based music player"
+url="http://cmus.sourceforge.net/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="alsa-lib-dev faad2-dev flac-dev libmad-dev opusfile-dev
+ libogg-dev libvorbis-dev ncurses-dev wavpack-dev linux-headers"
+install=""
+subpackages="
+ $pkgname-doc
+ $pkgname-zsh-completion:zshcomp
+ $pkgname-bash-completion:bashcomp"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cmus/cmus/archive/v${pkgver}.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ for file in AUTHORS README.md; do
+ install -Dm644 "${file}" "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+ done
+}
+
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+ arch="noarch"
+
+ install -Dm644 "$_builddir"/contrib/$pkgname.bash-completion \
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
+}
+
+zshcomp() {
+ depends=""
+ pkgdesc="Zsh completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+ arch="noarch"
+
+ install -Dm644 "$_builddir"/contrib/_$pkgname \
+ "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
+}
+
+md5sums="0588ab955db44a8e9deb03446d73b5df cmus-2.7.1.tar.gz"
+sha256sums="8179a7a843d257ddb585f4c65599844bc0e516fe85e97f6f87a7ceade4eb5165 cmus-2.7.1.tar.gz"
+sha512sums="b29ce10bbb61eb41c33c4912be320718fcf005a5797320145b124f048f6be5f5b0cebb67471ef7b062bd6f854849b6aae0e82e9adbf289a44237787932ea1576 cmus-2.7.1.tar.gz"